Closed Bug 1097878 Opened 5 years ago Closed 5 years ago

crash in mozilla::net::HttpChannelParentListener::OnDataAvailable(nsIRequest*, nsISupports*, nsIInputStream*, unsigned __int64, unsigned int)

Categories

(Core :: Networking, defect, critical)

x86
Windows NT
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla36

People

(Reporter: JasnaPaka, Assigned: dragana)

References

()

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-0866f3d6-9561-4c58-9a45-129ed2141112.
=============================================================
Random crash on Altap Salamander website (http://www.altap.cz/salamander/downloads/). I tried to download software -> crash. With second try it works (no crash). Latest Nightly, e10s enabled
Assignee: nobody → dd.mozilla
Attached patch fix v1Splinter Review
This is a missing part of patch for bug 1073872
Attachment #8521898 - Flags: review?(sworkman)
Comment on attachment 8521898 [details] [diff] [review]
fix v1

Review of attachment 8521898 [details] [diff] [review]:
-----------------------------------------------------------------

Looks sane to me. Good catch! r=me.
Attachment #8521898 - Flags: review?(sworkman) → review+
Blocks: 1073872
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/113e26c07fc1
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Maybe in "mozilla36" the issue was fixed, but "mozilla37" still has it: https://crash-stats.mozilla.com/report/index/f6517f6e-8158-48fa-81ec-a4bbf2141130

However, it is not easily reproducible since after the crash and restart FF did not immediately crash again at the same exact place.

So it looks like the bug now triggers only after you use FF for a while and it somehow accumulates certain level of craziness and crashes *only then*.
Blocks: 1106396
For easier tracking purposes I filed the signature from 37 as a separate bug: bug 1106396
This bug also perfectly alive and well in the latest Mozilla38 Nightly. Unfortunately, FF 37 has crashed so badly, that it could not even send a crash report (there was error). But I can assure that the crash was exactly the same as before.

Any plans to assign a software engineer to solve that?
Flags: needinfo?(dd.mozilla)
I am going to take a look at it soon. Just busy with other stuff

there is another bug for 37 bug 1106396.
Flags: needinfo?(dd.mozilla)
Closing this up as there are no more issues in Firefox 36, and crashes in 37 are tracked separately.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.