[Settings] The user feedback textbox resets if the screen is locked

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RobertM, Assigned: mancas)

Tracking

unspecified
2.2 S1 (5dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8521586 [details]
Flame2.1logcat.txt

Description:
While submitting User Feedback, if text is entered into the textbox, then the device is locked, when it is unlocked, all the text in the textbox is cleared.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141112001201
2) Tap 'Settings' app
3) Scroll to the bottom and tap 'Improve Firefox OS'
4) Tap 'Send Mozilla Feeback' bar
5) Tap 'Happy' or 'Sad' (doesn't matter which one)
6) Tap the textbox and enter some text
7) Press the power button to lock the screen
8) Unlock the device and observe
  
Actual:
The text box is now blank
  
Expected: 
The text box still has the previously entered text


Flame 2.1(319mb)(KitKat)(Shallow Flash)  

Device: Flame 2.1
BuildID: 20141112001201
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/QDIS5p8Q_S8
(Reporter)

Comment 1

3 years ago
This issue also occurs on Flame 2.0(319mb) and Flame 2.2(319mb)

When submitting user feedback, if the user locks the device after entering text into the comment box, when the device is unlocked, all the text is cleared.


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112000204
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: 1ff99565be67
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Nominating to block 2.0. Locking the device/ the device falling asleep should never erase text that the user has input.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(Assignee)

Updated

3 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 3

3 years ago
Created attachment 8522756 [details] [review]
Proposed patch

Arthur, could you review the patch when you get a chance?

Thanks!
Attachment #8522756 - Flags: review?(arthur.chen)
Comment on attachment 8522756 [details] [review]
Proposed patch

Please check my comment in github, thanks.
Attachment #8522756 - Flags: review?(arthur.chen)
[Blocking Requested - why for this release]:

[Triage] Suggest nom. to 2.1 or 2.2 for consideration considering current timing of 2.0.
blocking-b2g: 2.0? → 2.1?
(Assignee)

Comment 6

3 years ago
Comment on attachment 8522756 [details] [review]
Proposed patch

Hey Arthur, I took into account your comments. Please review it

Thanks!
Attachment #8522756 - Flags: review?(arthur.chen)
Comment on attachment 8522756 [details] [review]
Proposed patch

The code looks good! Could you add a test ensuring that `keepAllInput` is called only when document is hidden?
Attachment #8522756 - Flags: review?(arthur.chen) → feedback+

Comment 8

3 years ago
Triage: Not blocking, low user impact.
blocking-b2g: 2.1? → -
(Assignee)

Comment 9

3 years ago
Arthur, could you take a look at my comments in github? Thanks!
Flags: needinfo?(arthur.chen)
Please check my response in github, thanks.
Flags: needinfo?(arthur.chen)
(Assignee)

Comment 11

3 years ago
I've some problems with the unit tests, could you help me? I don't really know why the first test is working fine but not the second one.

Thanks
Flags: needinfo?(arthur.chen)
The reason is because `MockSendFeedback` returns a new instance every time you call to it. So `this.sendFeedback` is never be the same instance used in the panel. One way of fixing it would be make `MockSendFeedback` returns the same object.
Flags: needinfo?(arthur.chen)
(Assignee)

Comment 13

3 years ago
Comment on attachment 8522756 [details] [review]
Proposed patch

You're right! Now, you can review it when you get a chance

Thanks Arthur!
Attachment #8522756 - Flags: review?(arthur.chen)
Comment on attachment 8522756 [details] [review]
Proposed patch

We are almost there! Please check my comments, thanks.
Attachment #8522756 - Flags: review?(arthur.chen)
(Assignee)

Comment 15

3 years ago
Comment on attachment 8522756 [details] [review]
Proposed patch

Hey Arthur, I took into account your comments. Please, take a look at the PR.

Thanks!
Attachment #8522756 - Flags: review?(arthur.chen)
Comment on attachment 8522756 [details] [review]
Proposed patch

r=me, thank you!
Attachment #8522756 - Flags: review?(arthur.chen) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/64ba456b8aadc35a51171dd5cde29eaf8d62b79f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)
This bug has been verified as "pass" on latest nightly build of Flame v2.2 & Master by the STR in Comment 0.

Actual results: The text box still has the previously entered text after locking and unlocking screen.
See attachment: verified_Flame_v2.2.3gp
Reproduce rate: 0/10


Device: Flame v2.2 (Verified) 
Build ID               20150712002506
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d59402ba85a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150712.040416
Firmware Date          Sun Jul 12 04:04:27 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Verified)
Build ID               20150712010205
Gaia Revision          e4b63559eba364892867eb381c3002d6518e5d6a
Gaia Date              2015-07-10 14:29:23
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/eab21ec484bb
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150712.050401
Firmware Date          Sun Jul 12 05:04:12 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
status-b2g-master: --- → verified
Created attachment 8632683 [details]
verified_Flame_v2.2.3gp
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.