If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Email] Search Email option does not appear unless user scrolling up.

RESOLVED INVALID

Status

Firefox OS
Gaia::E-Mail
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Johnt, Assigned: robert.sajdok)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8521637 [details]
logcat_20141112_1223.txt

Description:
If the user has at least 6 emails in one of the email folders the search Email option will not appear unless the user scrolls up.
   
Prereq: Email account with at least 6 Emails in Inbox. (Or 6 emails in another email folder such as Sent and drafts.)

Repro Steps:
1) Update a Flame device to BuildID: 20141112001201
2) Sign into an Email account.
3) Select drawer button option, currently to the top right of device.
4) Select Inbox, or another Email folder with enough Emails into to enable scrollbar.
5) Scroll up to enable Search Email option.
  
Actual:
Scroll bar does not appear unless scrolling up.
  
Expected: 
It is expected that the user will see this search option before they decide to scroll through the current selected folder containing emails.

Flame 2.1(319mb)(KitKat)(Shallow Flash)  

Device: Flame 2.1
BuildID: 20141112001201
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: Logcat & Video
Video: https://www.youtube.com/watch?v=39MPP8UaHCg&edit=vd
(Reporter)

Comment 1

3 years ago
This issue also Occurs on the Flame 2.2 KK (319mb) and on the Flame 2.0 KK (319mb).

Result: Scroll bar does not appear unless scrolling up.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112000204
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: 1ff99565be67
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This seems like a minor issue, becuase the user can still view all the emails and find the search bar.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
I'm confused by comment 0 as to which of the following is the problem:

A) The search box should always be visible when entering a folder.

B) The search box does not need to always be visible, but the scroll bar should appear and then fade out to make it clear that scrolling is an option.


The current behaviour (the opposite of A) is intentional per UX design.  The fact that we show it when there aren't that many messages seems like a bug in our implementation.

And testing on b2g-desktop right now, it seems like 'B' is already true.  If it has ceased to be true I think that's a platform regression or decision which supersedes our own.
(Reporter)

Updated

3 years ago
Summary: [Email] Search Email option does not appear unless user scrolls up. → [Email] Search Email option does not appear unless user scrolling up.

Comment 4

3 years ago
Created attachment 8571610 [details] [review]
[gaia] rsajdok:bug#1097935 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → robert.sajdok
(Assignee)

Updated

3 years ago
Attachment #8571610 - Flags: review?(jrburke)
Comment on attachment 8571610 [details] [review]
[gaia] rsajdok:bug#1097935 > mozilla-b2g:master

The video seems to indicate what is the actual UX guidance we have had for email so far: explicitly to hide the search bar when in a default view for a folder.

So I am going to close this bug out as working as designed, and so the pull request is not needed.

If the reporter wishes to discuss it more, it is best to ni? Juwei, since she handles the UX for email, and any changes to this would need UX signoff.
Attachment #8571610 - Flags: review?(jrburke)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.