Closed Bug 1098090 Opened 5 years ago Closed 5 years ago

[Browser] Scrolling up and down in landscape mode after selecting and deselecting the browser link will cause the keyboard to open unexpectedly.

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1097941
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: jthomas, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3] [systemsfe])

Attachments

(1 file)

Description:
If the User enters the browser app in landscape mode and selects the rocket bar, then deselected the rocket bar and proceeds to scroll up and down, the keyboard will open and close.


Repro Steps:
1) Update a Flame device to BuildID: 20141112001201
2) Open Browser in Landscape mode.
3) Press the search link at the top.
4) Deselect the rocketbar.
5) Scroll up and down.
  
Actual:
Keyboard will open and disappear while scrolling up and down. Screen will dim.
  
Expected: 
It is expected that the user will be able to scroll up and down without the Search bar being briefly selected with the keyboard prompt.

Flame 2.1(319mb)(KitKat)(Shallow Flash)  

Device: Flame 2.1
BuildID: 20141112001201
Gaia: 4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko: b9849b3c6aaa
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: Logcat & Video
Video: http://youtu.be/G3SQD_-VuV0
This issue DOES occur on Flame 2.2 KK (319mb)
Result: Keyboard prompt does not appear but the screen is still dimming as though the keyboard would appear.


Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112040208
Gaia: 5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko: 688f821edcd4
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

------------------------------------------------------------------

This issue is NOT occuring on the Flame 2.0 KK (319mb).

Result: Keyboard prompt does not appear, nor does the screen dim.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141112000204
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: 1ff99565be67
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
After about 15 attempts on todays build, and speaking with the reporter, I was unable to get this bug to occur. Marking this as WFM. If this issue occurs agian, please re-open this bug.
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → WONTFIX
This bug shouldve been closed as a WFM, but it seems that this is actually a dupe of bug 1097941
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1097941
You need to log in before you can comment on or make changes to this bug.