Closed Bug 109810 Opened 18 years ago Closed 2 years ago

Way to manually add host names to Passwords-never-saved list in password manager

Categories

(SeaMonkey :: Passwords & Permissions, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: timeless, Unassigned)

References

Details

(Whiteboard: [obsoleted when bug 588421 lands])

Bug 109800 creates the interface required for this to work, but SignonViewer.js
gave me a headache so i'm asking for some help in putting together the JS
midlayer for this.

we need to talk about the best way to implement late commit adding so that it
plays nicely w/ having items added and removed before the commit happens and
other  stuff.  Or, if you happen to have an idea how to do it using this
interface i'd be glad to just let you do it.

my plan for the actual ui is probably:
+--------------------------------------------+
|Password Manager                          |X|
+--------------------------------------------+
|_(Passwords Saved[Passwords Never Saved]____|
| No login information will be saved for the |
| following sites:                           |
| [                               ] [ Add  ] |
| +----------------------------------------+ |
| |www.foo.com                             | |
| |:                                       | |
| |:                                       | |
| |:                                       | |
| +----------------------------------------+ |
| [Remove] [Remove All]                      |
|--------------------------------------------|
|                            [ OK  ] [Cancel]|
+--------------------------------------------+

The above is relatively consistent w/ the other tab, personally, i'd imagine
something like the following might be better if the other tab could have some
similar feature.

+--------------------------------------------+
|Password Manager                          |X|
+--------------------------------------------+
|_(Passwords Saved[Passwords Never Saved]____|
| No login information will be saved for the |
| following sites:                           |
| [                               ] [ Add  ] |
| +-------------------------------+          |
| |www.foo.com                    | [Remove] |
| |:                              | [Clear ] |
| |:                              |          |
| |:                              |          |
| +-------------------------------+          |
|--------------------------------------------|
|                            [ OK  ] [Cancel]|
+--------------------------------------------+
Depends on: 109800
Status: NEW → ASSIGNED
Component: Cookies → Password Manager
Target Milestone: --- → Future
See also bug 110363, "Image manager dialog should let me add/edit entries".
*** Bug 67429 has been marked as a duplicate of this bug. ***
Im not sure if the "Never" part is the most interesting thing about the manager,
the thing I would like to have is to be able to add login/password to pages that
aren´t usually recognized as loginpages.
(like Iplanet, etc etc)
Would it be perhaps possible to add a righclick-option to textboxes, (Add as
login+ Add as password) to a page?
To that there should be pretty easy to add a third option, (do not save any
login from this page)
With these additions, your proposed interface would be more than sufficent to
add and remove any faulty logins/non logins.
just my 2 cents.

The summary would be clearer, if put this way:

"Way to manually add sites to 'Passwords Never Saved' list in 'Password Manager'."
Reassigning to new module owner.
Assignee: morse → dveditz
Status: ASSIGNED → NEW
-> default qa.
QA Contact: tever → tpreston
Product: Browser → Seamonkey
Assignee: dveditz → nobody
QA Contact: tpreston
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Group: core-security
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Group: core-security
I reconfirm this.
This is clearly still relevant to the current product.
Status: UNCONFIRMED → NEW
Summary: Way to manually add to Passwords never saved list in passwordmanager → Way to manually add host names to Passwords-never-saved list in password manager
The new Data Manager in SeaMonkey 2.1 will support this once bug 588417 lands and ultimately, this bug will be obsoleted when the old password manager UI is being removed from SeaMonkey.
Whiteboard: [obsoleted when bug 588421 lands]
As stated you can do this using the Data Manager. The setting is now (2.49.1) shown in the permissions tab.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.