[System] When the alarm rings and the user presses Stop, the visual indicator at the top still moves

RESOLVED DUPLICATE of bug 1097675

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1097675
3 years ago
3 years ago

People

(Reporter: julienw, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
STR:
1. set the alarm at "current time +1min"
2. wait the alarm triggers
=> see that the visual indicator at the top moves
3. press "Stop"
=> see that the visual indicator at the top _still_ moves

The same issue happens if we make the alarm trigger by manually changing the time to a future time. 

Hey Michael, since this is the same visual indicator than we have for notifications, I think you'll know where this comes from?
Flags: needinfo?(mhenretty)
That is not the notification indicator, but the attention screen indicator I believe. I can confirm this is happening on master. qawanted for branch checks.
Flags: needinfo?(mhenretty)
Keywords: qawanted
Whiteboard: [systemsfe]
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: The attention indicator at the for the notification bar continues to animate for an alarm even if the alarm is stopped.

Repro Rate: 4/4

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141112125016
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 66cdb18f36da
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: The attention getter animation is not getting stuck on the status bar when it triggers.

Repro Rate: 0/6

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141112232645
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141112171043
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Contact: croesch
QA Contact: pcheng
This issue is actually NOT a regression. On 2.1 and 2.0 when the alarm is triggered, the blue-colored notification bar on top of screen does NOT display with the alarm. After examining the inbound pushlog we determined this is a feature that was implemented broken.

Posting the irrelevant inbound pushlog here for reference:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=78b4a6e815d8&tochange=8c1573307204
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: unaffected → ---
status-b2g-v2.1: unaffected → ---
Flags: needinfo?(jmitchell)
Keywords: regression, regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: pcheng
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1097675
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.