Web links loaded from Android homescreen should open an existing tab if it exists, to behave more like a webapp/Haida

RESOLVED DUPLICATE of bug 937253

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 937253
3 years ago
3 years ago

People

(Reporter: zac, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=java])

(Reporter)

Description

3 years ago
I have pinned several web links to my Android homescreen.

However, if I load these links twice, each one opens in a new tab inside Firefox Beta meaning that I have two tabs with the same content.

If Firefox were able to detect that the link is already open in one of the tabs and just open that tab instead it would stop the user from opening several tabs.

It would be one small step closer to having a weblink behave like a web app.

This logic already exists in Firefox desktop when you search in the Awesome bar, it will redirect you to an existing open tab.

Comment 1

3 years ago
We also have a switch-to-tab implementation in Fennec, so maybe we should just take that switch-to-tab code path when you open a homescreen shortcut. That sounds reasonable to me (and I agree, I also have a shortcut I use all the time and this is annoying).
Mentor: wjohnston@mozilla.com
Whiteboard: [lang=java]
This might be a good first step. Next steps might be to implement Web Manifest [1] and App Scope [2] on Android! :)

1. https://bugzilla.mozilla.org/show_bug.cgi?id=1003890
2. https://bugzilla.mozilla.org/show_bug.cgi?id=1038833
Dupe of bug 937253, which is fixed
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937253
You need to log in before you can comment on or make changes to this bug.