Closed Bug 1098259 Opened 5 years ago Closed 5 years ago

mach mochitest should auto-run mach mochitest-devtools

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1068676

People

(Reporter: pbro, Unassigned)

Details

Not everyone knows the different types of mochitests which exist, and the |mach mochitest| command helps with this a lot.
Unfortunately, it doesn't work for devtools tests.
One has to type |mach mochitest-devtools| for them to work.

Would it be possible to make |mach mochitest| also run devtools subsuite mochitests?
I suspect the only reason it doesn't already work is because devtools is a subsuite, and we filter that out. If you pass a devtools test on the commandline, however, we ought to be able to figure that out.
I've also noticed that |mach test| doesn't know about mochitest-devtools.
Duplicate of this bug: 1122590
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #1)
> I suspect the only reason it doesn't already work is because devtools is a
> subsuite, and we filter that out.

Is it possible to not filter a subsuite in this case?
Flags: needinfo?(ted)
Anything is possible, it's just software! We already have code to ignore "skip-if" when running a single test, this could be handled similarly.
Flags: needinfo?(ted)
I think this is a dupe of 1068676, which just landed in fx-team.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068676
You need to log in before you can comment on or make changes to this bug.