mouse-hover over suggested url list takes precedence over the contents of urlbar when pressing enter

RESOLVED DUPLICATE of bug 1043584

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1043584
4 years ago
4 years ago

People

(Reporter: ultramage, Unassigned)

Tracking

32 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140916130324

Steps to reproduce:

1. typed 'y' into urlbar and had youtube.com autocompleted
2. had the mouse cursor over the suggested urls dropdown list
3. moved the mouse at least 1px
4. pressed Enter


Actual results:

Because of 2) and 3) one of the suggested urls got highlighted, and pressing Enter made Firefox go to that url instead of what was currently in the urlbar.


Expected results:

I wanted to visit the page in the urlbar. Hovering over one of the items with the mouse is usually followed by a mouse click, and that's how it should happen. This mixed keyboard/mouse interaction was not what I intended. However you should still be able to use Enter to visit one one of the suggested urls selected using keyboard navigation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
You need to log in before you can comment on or make changes to this bug.