Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1102965
3 years ago
3 years ago

People

(Reporter: gerard, Assigned: albertopq)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: 1068963)

(Reporter)

Description

3 years ago
Looks to be a regression from bug 1062819 (not present just before, present with this commit), at least on current master. This is making my work on bug 1090859 quite harder.

STR:
 0. Disable lockscreen (via settings.json)
 1. Perform reset-gaia

Expected:
 SIM PIN dialog shown.

Actual:
 SIM PIN dialog is not shown.

Another set of STRs is also:
 0. Boot with 2 SIMs with PIN codes
 1. When presented the first SIM PIN dialog, press Skip

Expected:
 Dialog for SIM 2 PIN code is shown

Actual:
 Dialog is not shown, SIM 2 stays locked.
Following the 2nd set of STRs from Comment 0, I was unable to reproduce on Flame 2.1.

Result: The dialog for each PIN is displayed properly.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141113001200
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
I don't see this but see https://bugzilla.mozilla.org/show_bug.cgi?id=1092393#c19 in master for my flame with 2 locked sim.
Adding qawanted to see if they can reproduce this issue.
Flags: needinfo?(ktucker)
Keywords: qawanted
Strike Comment 3. Let's get a regression window instead.
Keywords: qawanted → regressionwindow-wanted
QA Contact: jmercado
The results I was seeing when reproducing the bug with the second steps from comment 2 are that the SIM Pin 1 dialogue was not shown but the SIM Pin 2 Dialogue is.  I considered this a repro and found the following Regression Window but the two bugs in the pushlog don't really seem related and now I'm not sure I was correctly reproducing.  NI? Alexandre for confirmation that what I saw was correct.

Central Regression Window:

Last Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141011130225
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: b6dc73e98dc2
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141011132225
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Version: 35.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Broken gaia / First Working gecko - Issue does NOT occur
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 44168a7af20d

First Working gaia / Last Broken gecko - Issue DOES occur
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: b6dc73e98dc2

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/95f580a1522ffd0f09302372b78200dab9b6f322...717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Whiteboard: 1068963
(Reporter)

Comment 6

3 years ago
Given the gaia pushlog you have, merged on october 11th, I don't think you are getting the same issue. Your description more matches what Gregor was experiencing in bug 1090859 comment 14.
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Updated

3 years ago
Flags: needinfo?(jmercado)
Someone else will have to try this then.
Flags: needinfo?(jmercado)
blocking-b2g: 2.2? → 2.2+

Comment 8

3 years ago
Hi Jayme, can you help to find someone on this? thanks
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Are you able to steal this from me :)?
Flags: needinfo?(apastor)
(Assignee)

Comment 10

3 years ago
Sure, I'll take a look. Thanks!
Assignee: alive → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 11

3 years ago
Is this a dupe of Bug 1102965? Flagging qawanted, as last check was before 1102965 was fixed.
Keywords: qawanted
This is next priority.
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
QA Contact: jmercado → pcheng
I'm unable to reproduce the following original issue on latest master:

(In reply to Alexandre LISSY :gerard-majax from comment #0)
> STR:
>  0. Disable lockscreen (via settings.json)
>  1. Perform reset-gaia

I see SIM pin dialog showing up.

As for the following,

> Another set of STRs is also:
>  0. Boot with 2 SIMs with PIN codes
>  1. When presented the first SIM PIN dialog, press Skip

I believe this is a dupe of bug 1100608 which has been recently fixed.


Removing qawanted and window-wanted due to both issues being fixed.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted, regressionwindow-wanted
(Assignee)

Comment 14

3 years ago
Thanks!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102965
blocking-b2g: 2.2+ → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.