Menus should highlight when items they contain are activated by keyboard shortcuts on Mac OS

VERIFIED DUPLICATE of bug 50590

Status

()

--
trivial
VERIFIED DUPLICATE of bug 50590
17 years ago
10 years ago

People

(Reporter: mozilla7, Assigned: hyatt)

Tracking

Trunk
PowerPC
Mac System 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5+) Gecko/20011109
BuildID:    2001110908

When a keyboard shortcut is pressed to activate an item in a menu, the menu in
the menubar should briefly highlight.  All other Mac apps do this (or at least
they're supposed to).

Reproducible: Always
Steps to Reproduce:
1. Select some text
2. Press Command-C to copy

Actual Results:  There is no visual feedback

Expected Results:  The Edit menu should briefly highlight

This is somewhat related to Bug 66120.

Comment 1

17 years ago
-> pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
From bug 50590:

------- Additional Comments From Matthew Thomas (mpt) 2000-09-12 17:21 -------
But whatever, that's a minimum interval; if the operation itself takes longer 
than 8/60 of a second (e.g. pasting a large quantity of text), the menu should 
stay lit for the whole operation. We already do this for opening dialogs, so 
presumably it's possible for other operations.

Comment 3

17 years ago
Whoops, ignore that.  Too many similarly-numbered bugs open at one time.

*** This bug has been marked as a duplicate of 50590 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.