Closed Bug 1098421 Opened 6 years ago Closed 6 years ago

Aurora stops unexpectedly when trying to launch Search Activity from the widget

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

35 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox35 affected, firefox36 unaffected, fennec35+)

RESOLVED WORKSFORME
Tracking Status
firefox35 --- affected
firefox36 --- unaffected
fennec 35+ ---

People

(Reporter: cos_flaviu, Assigned: Margaret)

References

Details

Attachments

(1 file)

Environment: 
Device: Samsung Galaxy R (Android 2.3.4);
Build: Aurora 35.0a2 (2014-11-13);

Steps to reproduce:
1. Launch Search Activity from the widget;

Expected result:
Search Activity is successfully launched.

Actual result:
Aurora stops unexpectedly when trying to launch Search Activity from the widget.

Notes:
After the unexpected stop there is no visible action when tapping on any button from Search Activity widget.
Aurora also stops unexpectedly right after device is turned on.

Only reproducible on gingerbread devices.
Blocks: search, widget
tracking-fennec: --- → ?
If Fx36 is unaffected, let's figure out what needs to be uplifted.
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 35+
I can't reproduce this on a Nexus S running 2.3.6 or a Galaxy SII running 2.3.4.

kbrosnan says there's a Galaxy R in MV, maybe he can bring that up to SF, or wesj could also look into this.
wesj, can you try to reproduce this on the Galaxy R in MV?
Flags: needinfo?(wjohnston)
NI for over a month. Can we get this rolling?
I'll be in MV on Thursday, so I can also try this myself if there's a Galaxy R down there.
It should be in QA Lab. You may need a QA member to give you access.
I can't reproduce this on a Galaxy R (2.3.6) on Beta (35) or Aurora (36).

Is this still an issue?
Flags: needinfo?(wjohnston) → needinfo?(flaviu.cos)
(In reply to :Margaret Leibovic from comment #7)
> I can't reproduce this on a Galaxy R (2.3.6) on Beta (35) or Aurora (36).
> 
> Is this still an issue?

The issue is no longer reproducible.
Flags: needinfo?(flaviu.cos)
(In reply to Flaviu Cos, QA [:flaviu] from comment #8)
> (In reply to :Margaret Leibovic from comment #7)
> > I can't reproduce this on a Galaxy R (2.3.6) on Beta (35) or Aurora (36).
> > 
> > Is this still an issue?
> 
> The issue is no longer reproducible.

In fact the scenario is a bit different:
The Search Activity can be launch from the widget only if Auroa is running in background. Otherwise Search Activity pops up for a second and then it closes.

I attached the logs from logcat with the exceptions that are thrown while trying to launch Search Activity from the Search widget.
Flags: needinfo?(margaret.leibovic)
(In reply to Flaviu Cos, QA [:flaviu] from comment #9)
> Created attachment 8539192 [details]
> search activity logs.txt
> 
> (In reply to Flaviu Cos, QA [:flaviu] from comment #8)
> > (In reply to :Margaret Leibovic from comment #7)
> > > I can't reproduce this on a Galaxy R (2.3.6) on Beta (35) or Aurora (36).
> > > 
> > > Is this still an issue?
> > 
> > The issue is no longer reproducible.
> 
> In fact the scenario is a bit different:
> The Search Activity can be launch from the widget only if Auroa is running
> in background. Otherwise Search Activity pops up for a second and then it
> closes.
> 
> I attached the logs from logcat with the exceptions that are thrown while
> trying to launch Search Activity from the Search widget.

Does this only happen on Aurora? This bug was initially reported when Aurora was Firefox 35, so is this on Beta?

wesj still has the phone in MV, so maybe he can try to reproduce.
Flags: needinfo?(margaret.leibovic) → needinfo?(wjohnston)
Flaviu, can you help me narrow down exactly which versions of Firefox are affected here, and what exactly is happening? At this point we're not going to be able to get a fix in for Firefox 35, but I would like to get a fix in to close out this bug.
Flags: needinfo?(flaviu.cos)
I can not reproduce the issue any more.
Works fine on all channels.

It may have been some issues with the device.
Flags: needinfo?(flaviu.cos)
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(wjohnston)
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.