Closed Bug 1098431 Opened 5 years ago Closed 5 years ago

Popups inside developer tools appear in the wrong location

Categories

(DevTools :: Framework, defect)

34 Branch
x86
All
defect
Not set

Tracking

(firefox33 unaffected, firefox34- wontfix, firefox35+ fixed, firefox36+ fixed)

RESOLVED FIXED
Firefox 36
Tracking Status
firefox33 --- unaffected
firefox34 - wontfix
firefox35 + fixed
firefox36 + fixed

People

(Reporter: bronzehedwick, Assigned: bgrins)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141113004001

Steps to reproduce:

1. Open developer tools Inspector.
2. Inspect an element that has an event listener.
3. Click the ev icon.

OR

1. Open the developer tools Style Editor.
2. Click the gear icon on the left.

OR

1. Open the developer tools settings.
2. Click any dropdown.

Basically, anything that creates a modal popup inside developer tools.


Actual results:

The appropriate popup appears far away from the original element being selected.


Expected results:

The popup should appear directly above or next to the element that spawn it.
It regressed since 34.

good=2014-08-12
bad=2014-08-13
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b53c2753ce9a&tochange=7fc96293ada8

Possible suspected bug:
Allison Naaktgeboren — Bug 1030451-Update spellchecker context menu suggestions for multiprocess.r=billm
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL Widgets
Ever confirmed: true
Keywords: regression
Product: Firefox → Toolkit
Version: 33 Branch → 34 Branch
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=e710d09d521a&tochange=f0f57896a851

Regressed by:
f0f57896a851	Brian Grinstead — Bug 1050857 - Options panel layout doesn't work well with translated text;r=mratcliffe
Blocks: 1050857
Flags: needinfo?(bgrinstead)
OS: Mac OS X → All
Component: XUL Widgets → Developer Tools: Framework
Product: Toolkit → Firefox
(In reply to Alice0775 White from comment #2)
> https://hg.mozilla.org/integration/fx-team/
> pushloghtml?fromchange=e710d09d521a&tochange=f0f57896a851
> 
> Regressed by:
> f0f57896a851	Brian Grinstead — Bug 1050857 - Options panel layout doesn't
> work well with translated text;r=mratcliffe

So out of the three STR in the description, only the last one is reproducible?  Not the events popup in the inspector or gear on the style editor?
Following my testing, yes, only drop-down lists of the settings dev panel are bad positionned.
OK, so the change here: https://hg.mozilla.org/integration/fx-team/rev/f0f57896a851 was to allow word wrapping within the options panel (so converting from <label value="foo" /> to <label>foo</label>.

I'm not sure why, but wrapping the <menulist> elements in <hbox> seems to maybe fix this.  Here is a try push that I think will fix it: https://tbpl.mozilla.org/?tree=Try&rev=2d2a7726bf8e
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Mike, I'm not sure exactly why this fixes the popup positioning for the dropdowns, but it seems to.  Maybe you will know why?
Attachment #8522684 - Flags: review?(mratcliffe)
Loic, can you confirm that this build fixes the problem? https://tbpl.mozilla.org/?tree=Try&rev=2d2a7726bf8e
Flags: needinfo?(epinal99-bugzilla2)
Comment on attachment 8522684 [details] [diff] [review]
options-popup-positioning.patch

Review of attachment 8522684 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Brian Grinstead [:bgrins] from comment #6)
> Created attachment 8522684 [details] [diff] [review]
> options-popup-positioning.patch
> 
> Mike, I'm not sure exactly why this fixes the popup positioning for the
> dropdowns, but it seems to.  Maybe you will know why?

There is no obvious reason so I suspect this is a XUL bug. The workaround looks good so r+
Attachment #8522684 - Flags: review?(mratcliffe) → review+
see also bug 1055702.
I spoke with dcamp. He's not concerned about fixing this in 34. He does want this in 35, which is currently dev edition.
https://hg.mozilla.org/mozilla-central/rev/79f77bfe502d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
Flags: needinfo?(epinal99-bugzilla2)
Thanks everyone! This is the first bug ticket I've reported for FF, and the response is amazing. Such a great community here.
Comment on attachment 8522684 [details] [diff] [review]
options-popup-positioning.patch

Approval Request Comment
[Feature/regressing bug #]: 1050857
[User impact if declined]: Popups in the options panel in devtools show up in the wrong location
[Describe test coverage new/current, TBPL]: The options panel has existing test coverage for functionality, but this was a positioning issue in xul that required wrapping <menulist> elements with an <hbox> element
[Risks and why]: Pretty low risk, the change is limited to the options panel in devtools, and just wraps some existing elements into a parent <hbox>
[String/UUID change made/needed]: None
Attachment #8522684 - Flags: approval-mozilla-aurora?
Attachment #8522684 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1055178
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.