bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

System Update splash screen (just before the reboot) has awkwardly-placed text & cropped image, if phone is in landscape mode

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: dholbert, Assigned: cwiiis)

Tracking

unspecified
2.2 S1 (5dec)

Firefox Tracking Flags

(feature-b2g:2.2+, tracking-b2g:backlog, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
STR:
1. Start downloading an OTA system update. (I'm on Flame Aurora channel, using a normal nightly system update on that channel.)

2. Open an app that supports landscape mode (like Browser), and hold the phone in landscape mode.

3. When your update finishes downloading, hit the button to accept the update & reboot.

ACTUAL RESULTS: The "System Update" splash screen is really oddly displayed.
 - The text "System Update" is towards the lower-left of the screen.
 - The image is partially pushed off the bottom of the screen.

See upcoming photo for an example.


I'm hitting this on the Flame 2.1 "Aurora" channel. (Noticed it a week or so ago, & just tried & reproduced it again, installing the latest update.)
(Reporter)

Comment 1

4 years ago
(mhenretty, maybe you could take a look, or know who the right person to take a look would be?)
Flags: needinfo?(mhenretty)
[Blocking Requested - why for this release]:
Let's see how bad it looks in the photo and decide whether or not to block.
Blocks: 1061466
blocking-b2g: --- → 2.1?
Flags: needinfo?(mhenretty)
Whiteboard: [systemsfe]
(Reporter)

Comment 3

4 years ago
Created attachment 8522411 [details]
photo
(Reporter)

Comment 4

4 years ago
(Yes, that's a screen crack; that part is not the fault of this bug. :))
I believe we need visual specs for the landscape mode.
Flags: needinfo?(firefoxos-ux-bugzilla)
Bad UX bug but not blocking because too late in the game, user impact is minimal and user that buys the phone doesn't see it every day.
Lets fix on master and uplift if its a low risk patch.
blocking-b2g: 2.1? → backlog
feature-b2g: --- → 2.2+

Comment 7

4 years ago
This belongs to Jenny. This is a standard component so i don’t think it’d be visual design but Jenny, please re-assign if so.

Updated

4 years ago
Flags: needinfo?(jelee)

Comment 8

4 years ago
This is definitely something we want to fix, but I think maybe this is more of a visual problem?
Hi Eric, is this covered by you ;)?
Flags: needinfo?(jelee) → needinfo?(epang)
(In reply to Jenny Lee from comment #8)
> This is definitely something we want to fix, but I think maybe this is more
> of a visual problem?
> Hi Eric, is this covered by you ;)?

Hi Jenny, thanks for flagging me on this.  The contents should be veritcally centered on the screen the way they are in portrait :). Thanks!
Flags: needinfo?(epang)
just wanted to add that this should be part of the building blocks.  Does this happen for all confirm screens?  If so, the building blocks may need to be fixed to correct this issue.
Flags: needinfo?(firefoxos-ux-bugzilla)
Chris, can you take care of this?
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 12

4 years ago
Created attachment 8527731 [details] [review]
Fix system update splash in landscape
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
Attachment #8527731 - Flags: review?(alive)
Comment on attachment 8527731 [details] [review]
Fix system update splash in landscape

css only change, r=me
Attachment #8527731 - Flags: review?(alive) → review+
(Assignee)

Comment 14

4 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/41b7be7c67167f367c3c4982ff08651d55455373
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S1 (5dec)
Issue verified fixed on Flame 3.0

When user performs OTA update from old 3.0 (02/06 nightly) to current 3.0 nightly, the splash screen is vertically and horizontally centered regardless of whether the screen is in portrait or landscape mode. No part of the splash screen element is cut off by screen edges. (OTA was performed from Flame 3.0 build 20150206010204 to Flame 3.0 build 20150209010211)

Device: Flame 3.0 Master
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Adding verifyme for 2.2 verification.
Keywords: verifyme
Created attachment 8561948 [details]
Verify_video.mp4

The problem is verified not happen on latest Flame 2.2 build.

Steps:
1. Flash Flame 2.2 build(20150209002504).
2. Modify update channel.
3. Check update and download.
4. Open brower.
5. flip the phone to landscape mode. 
6. Wait for updates download complete.
7. Execut update.

Actual Result:
7.No part of the splash screen element is cut off by screen edges.
(OTA was performed from Flame 2.2 build 20150209002504 to Flame 2.2 build 20150209162506)

Fail rate:0/5
See attachment:Verify_video.MP4

Flame 2.2 version:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Keywords: verifyme
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.