Closed Bug 1098505 Opened 7 years ago Closed 6 years ago

[Flame v188 and v18D Base Image] [WiFi Tethering] - WiFi tethering does not work

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: rdaub, Unassigned)

References

Details

(Whiteboard: [SUMO-b2g])

Attachments

(7 files)

WiFi Tethering does not seem to work on a Flame with v188 Base Image.

ENVIRONMENT:
Device Model: Flame
Version: 2.0.0.0-prerelease
BuildID: 20141021162107

STEPS TO REPRODUCE:
1. Turn on Data and WiFi tethering on the Flame device.
2. Connect "Android Device" or "Firefox OS device" to the Flame.

EXPECTED RESULTS:
"Android Device" and/or "Firefox OS device" should be able to use Flame's data connection to browse online, download apps, etc.

ACTUAL RESULTS:
Both "Android Device" and "Firefox OS device" connect to the WiFi tethering network but are not able to connect to the Internet. I get "check your connection" type of errors.

ADDITIONAL INFORMATION:
On a Flame with v188 build and v2.1 Full Image flash, the tethering works well using the same SIM card.


Please let me know if there is any other information that may be helpful to investigate and troubleshoot this issue.

Thanks!
Attached file WiFi-tethering.log
steps taken in logcat:
1. Turn on WiFi Tethering on "Flame Device"
2. Connect "Android Device" to "Flame Device"
3. Do a search on "Android Device's" Firefox for Android
4. Connect "Alcatel OneTouch Fire" to "Flame Device"
5. Disconnect "Android Device" from "Flame Device"
6. Do a search on "Alcatel OneTouch Fire's" browser.
7. Turn off WiFi tethering on "Flame Device"
Hi Ralph, I updated the nightly 2.0 flame-kk build based on v188. But I can use wifi tethering function successfully. Below is my version information.  

Gaia-Rev        28991b28d54fc4ef8112c8fa678bf20f9faca8c8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/62294be0fc98
Build-ID        20141113160200
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141113.192853
FW-Date         Thu Nov 13 19:29:01 EST 2014
Bootloader      L1TC00011880

Can you help to help to some information using below commands?

1. "iptables -nvL"
2. "netcfg"
3. "cat /proc/sys/net/ipv4/ip_forward"
4. "ps | grep -e dnsmasq -e hostapd  -e radish"

It would be nice if you could also provide "adb logcat" log when turning on wifi tethering.
BTW, it seems that wifi tethering can't be turned on due to some netd commands error. I would like to confirm that if you turn on 3G data connection before turn on wifi tethering ?
See Also: → 1097902
Vincent,

I'm adding NI for myself as a reminder. I did a shallow-flash on my device so that I could keep using it as a daily driver, but I will attempt another v188 flash on a Flame and follow up on it.

Thanks! =)
Flags: needinfo?(rdaub)
Hi Youlong, please help check the log and let us know what happened, thank you.
Flags: needinfo?(youlong.jiang)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1095177
1. Turn on Data and WiFi tethering on the Flame device.
2. Connect "Android Device" or "Firefox OS device" to the Flame.

I tested it is ok, I can use wifi tethering function successfully on v188.

 T2Mobile Limited
(In reply to Ralph Daub [:rdaub] from comment #4)
> Vincent,
> 
> I'm adding NI for myself as a reminder. I did a shallow-flash on my device
> so that I could keep using it as a daily driver, but I will attempt another
> v188 flash on a Flame and follow up on it.
> 
> Thanks! =)

hi Ralph -

per comment#7 result, could you pls share the reproduce step by detail

tks.
Flags: needinfo?(youlong.jiang) → needinfo?(wehuang)
1. Can't repro. w/ v188 base image. (maybe need clearer STR?)
2. Nothing abnormal found in existing log, need more log.

@Ralph, would you help?
Flags: needinfo?(wehuang)
I am still able to reproduce this issue.

I flashed a new flame device with v188 (BuildID 20141021162107) and followed the STR from comment 0. 

I am undoing "Marked as Duplicate" and reopening this bug because:
* bug 1095177 is for an issue with hotspot not being visible.
* In this bug, and according to comment 0, I can see the hotspot and I can connect to it, but the devices connected to the hotspot have no access to the Internet.

Vincent, on the tests you performed in Comment 2, did you do a full-flash / shallow-flash on top of a v188 Base Image? I am reproducing this on a Flame device with *only* v188 Base Image.

I am including attaching all the commands requested in comment 2, while connected to the Hotspot device via Adb Shell.
Status: RESOLVED → REOPENED
Flags: needinfo?(rdaub)
Resolution: DUPLICATE → ---
Attached file iptables -nvL.log
Attached file netcfg.log
Attached file ip_forward.log
Attached file ps.log
Attached file WiFi-tethering(2).log
Flags: needinfo?(vchang)
(In reply to Ralph Daub [:rdaub] from comment #10)
> I am still able to reproduce this issue.
> 
> I flashed a new flame device with v188 (BuildID 20141021162107) and followed
> the STR from comment 0. 
> 
> I am undoing "Marked as Duplicate" and reopening this bug because:
> * bug 1095177 is for an issue with hotspot not being visible.
> * In this bug, and according to comment 0, I can see the hotspot and I can
> connect to it, but the devices connected to the hotspot have no access to
> the Internet.
> 
> Vincent, on the tests you performed in Comment 2, did you do a full-flash /
> shallow-flash on top of a v188 Base Image? I am reproducing this on a Flame
> device with *only* v188 Base Image.
> 
> I am including attaching all the commands requested in comment 2, while
> connected to the Hotspot device via Adb Shell.

hi ralph -

I mean not re-flash gaia/gecko part, just use base image v188 for test, can you reproduce?

also could you pls double confirm that the hotspot device is able to surf on internet or just connected device has no ability.

tks.
Youlong: as discussed your people see something from log, so have doubt of the hotspot device in comment#16. Would you put more information here?
Flags: needinfo?(youlong.jiang)
Hi Ralph

 As you provide netcfg.log 
 "remnet0  UP" means that you have turned on the SIM "Data connetction",
 but "0.0.0.0/0" means the hospot device do not get a effective ip,
 it maybe the reason why other phone can't through its connect to the Internet.
Attached file netcfg.log
You can see my log
Hi  youlong.jiang,

The hotspot device (the Flame device with v188 and BuildID: 20141021162107) can access the Internet normally. The other devices connected to the Flame device are not able to access the Internet.
(In reply to Ralph Daub [:rdaub] from comment #20)
> Hi  youlong.jiang,
> 
> The hotspot device (the Flame device with v188 and BuildID: 20141021162107)
> can access the Internet normally. The other devices connected to the Flame
> device are not able to access the Internet.

hi Ralph -

as chao.liang mentioned before, we catch abnormal in your netcfg.log and found probably your hotspot device can't access the Internet, pls take a double confirm about it.

also we wanna to reproduce this issue just on v188, not re-flash your gaia/gecko version.

tks.
Flags: needinfo?(youlong.jiang)
Flags: needinfo?(rdaub)
(In reply to youlong.jiang from comment #21)
> 
> as chao.liang mentioned before, we catch abnormal in your netcfg.log and
> found probably your hotspot device can't access the Internet, pls take a
> double confirm about it.
> 
> also we wanna to reproduce this issue just on v188, not re-flash your
> gaia/gecko version.

Hi  youlong.jiang,

As per comment 0, comment 10, and comment 20, I already reproduced this issue on a Flame device with only the base image v188 flashed.

I re-downloaded v188 and the newer v18D base images, re-flashed the Flame device, and performed the tests again.

TEST RESULTS:
This issue REPRODUCES on v188 Base Image
- Firefox OS v2.0.0.0-prerelease-
- BuildID 20141016183911
- Git Commit info 2014-10-10 07:25:55


This issue REPRODUCES on the latest v18D Base Image
- Firefox OS v2.0.0.0-prerelease-
- BuildID 20141215191148
- Git Commit info 2014-12-15 08:12:45


This issue DID NOT REPRODUCE on v18D Base Image with shallow flash Gecko + Gaia v2.0
- Firefox OS v2.0.0.0-prerelease
- BuildID 20150203000206
- Git Commit info 2015-01-22 21:13:40


This issue DID NOT REPRODUCE on v18D Base Image with v2.0 Full Image Flash
- Firefox OS v2.0.0.0-prerelease
- BuildID 20150230000206
- Git Commit info 2015-01-22 21:13:40


From my tests, I can clearly see once again that the Base Image v188 has a faulty regression on the "Internet Sharing" feature, and that this issue also carried over to the latest Base Image v18D.

Adding needinfo to Hermina Condei to loop her in on the possible implications of this from a User Success perspective.

- Ralph
Flags: needinfo?(rdaub) → needinfo?(hcondei)
Summary: [Flame v188 Base Image] [WiFi Tethering] - WiFi tethering does not work → [Flame v188 and v18D Base Image] [WiFi Tethering] - WiFi tethering does not work
I can't reproduce the problem using Flame with M-C build. I would like to close it. Please reopen if you find the problem.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: needinfo?(vchang)
Resolution: --- → WORKSFORME
Flags: needinfo?(hcondei)
You need to log in before you can comment on or make changes to this bug.