[Clock] Starting an alarm 2 minutes away phone will start alarm will state alarm is set for 1 minute

NEW
Unassigned

Status

Firefox OS
Gaia::Clock
3 years ago
3 years ago

People

(Reporter: RJ, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8522430 [details]
logcat_20141113_1124.txt

Description:
Starting an alarm 2 minutes away phone will state alarm will state alarm is set for 1 minute and at times the analog clock will jump ahead to meet this


Repro Steps:
1) Update a Flame to 20141113001200
2) Go to clock 
3) Set alarm for 2 minutes ahead
4) Tap done 


Actual:

Timer is set and states wrong time 

Expected:
Timer is set and states right time 

Environmental Variables:
Device: Flame 2.1
Build ID: 20141113001200
Gaia: 569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko: d188e92aa5a6
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency:100%
See attached: logcat,video clip: https://www.youtube.com/watch?v=cs8VpNa0boA
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue DOES  occur on  2.2 (319mb)(Kitkat Base)(Shallow Flash) and 2.0 (319mb)(Kitkat Base)(Shallow Flash)
lag occurs

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113040205
Gaia: be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko: ab137ddd3746
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


-------------------------------------------------------------------------------------------------

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113000201
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Im pretty sure that this is intended behaviour. NI Clock owner to be sure.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(edchen)

Comment 3

3 years ago
Hi Derek - I suppose you thought timer is display wrong time. It should be showed 2 mins, right?
In my opinion, although this issue is not a bug, but absolutely belong to user experience issue. Since user always confused why Timer is fall away 1 min.
Flags: needinfo?(edchen)
You need to log in before you can comment on or make changes to this bug.