Add meta description to www.mozilla.org homepage and mozorg base templates

RESOLVED DUPLICATE of bug 1131331

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 1131331
3 years ago
3 years ago

People

(Reporter: cmore, Unassigned)

Tracking

(Blocks: 1 bug)

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1578807] [fxgrowth])

(Reporter)

Description

3 years ago
Looks like this is a regression of bug 394393 and bug 632665. (oldies!)

The meta description is missing from the www.mozilla.org homepage and thus it causes search engines to guess for the right text. Sometimes it is showing up as "Your system doesn't meet the requirements to run Firefox. Firefox Free Download English (US) Windows · Firefox Free Download English (US) Linux · Firefox  ..." and that could be confusing to visitors who are viewing the search results.

The meta description is in the base template:

https://github.com/mozilla/bedrock/blob/master/bedrock/base/templates/base-resp.html#L22

It can be overridden at the page template level like it is on the new.html as:

{% block page_desc %}{{_('Download Mozilla Firefox, a free Web browser. Firefox is created by a global non-profit dedicated to putting individuals in control online. Get Firefox today!')}}{% endblock %}

Given that it doesn't look like we include the page_desc in any of the mozorg templates, can we add it to the base-resp.html template so that all pages that use the mozorg base template has the same generic meta description?

https://github.com/mozilla/bedrock/blob/master/bedrock/mozorg/templates/mozorg/base-resp.html

We could use an existing string, so we don't have to come up with something new.

{{ _('Our mission is to promote openness, innovation & opportunity on the Web.')}}

from mission.html

We'll have to check with the L10N team to make sure we use a string that we have already know that would be available to be used on any mozorg template that doesn't already have a custom page_desc
(Reporter)

Updated

3 years ago
Whiteboard: [fxgrowth]

Updated

3 years ago
Whiteboard: [fxgrowth] → [kb=1578807] [fxgrowth]

Updated

3 years ago
Blocks: 745355

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131331
You need to log in before you can comment on or make changes to this bug.