Network selection not coming back up after failed manual selection

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: pgravel, Assigned: arthurcc)

Tracking

unspecified
2.2 S4 (23jan)

Firefox Tracking Flags

(blocking-b2g:2.2+, tracking-b2g:+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [caf priority: p2][CR 754800])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Go to settings- > Cellular and data
2. Tap on the Network operator ->change the network mode and then disable the Automatic selection.
3. Then List of the operators will be displayed.
4. Select the wrong operator.
5. Connection will fail and then device will go to Out of service state
6. Tap on the back key present at top left corner.
7. Now again tap on the network operator and it will no longer display the manual network selection options, so user cannot select another network or re-enable automatic selection.
(Reporter)

Comment 1

5 years ago
[Blocking Requested - why for this release]: Usability issue
blocking-b2g: --- → 2.1?
Adding qawanted to check if this happens on 2.0.
Keywords: qawanted
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.0 KK

Actual Results: Manual selection of network operator disappears and is no longer selectable.

Repro Rate: 2/2

Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141112171043
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
also setting 2.1 flag to affected based on comment 0 and comment 1
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Whiteboard: [CR 754800]
Whiteboard: [CR 754800] → [caf priority: p2][CR 754800]
It seems that after coming back to the panel, if you wait for just a few seconds the "auto" mode is activated and then you can change the network again. I don't really like this behavior but we need more info from a proper person.
Keywords: regression
Can QA/pgravel confirm if the scenario is recoverable which comment #5 mentions or by killing the settings app etc?
If this is recoverable this seems edge-casey and I am not sure we will block on this. But lets wait for QA to get back.
Flags: needinfo?(jmitchell)
I checked comment 5's workaround and found that if you go back one screen to the Cellular and Data screen from the Network Operator screen after the bug occurs, just waiting does not ever produce the manual selection again. 

I actually had to quit out of settings app completely then relaunch and go back into network operator. The user will get the ability to manually select again.
QA Contact: croesch
(In reply to Cody Roesch [:croesch] from comment #7)
> I checked comment 5's workaround and found that if you go back one screen to
> the Cellular and Data screen from the Network Operator screen after the bug
> occurs, just waiting does not ever produce the manual selection again. 

Sorry
I meant you need to go back to cellular and data then back into network operator screen and wait. After reading that previous comment it seemed confusing so i wanted to clarify.
pgravel, given this is recoverable I am hesitant to block here but given this is a regression from 1.4 (per offline conversation with ikumar) I am NI'ing settings owner to see how easy the fix would be so we can fix this atleast in the future release or uplift if this is an absolute ship-blocker for CAF.
Flags: needinfo?(timdream)
Flags: needinfo?(jmitchell)
Is this really a bug in Settings app, not the API?
Flags: needinfo?(timdream) → needinfo?(arthur.chen)
This reminds me bug 1022710 that we resolved in 2.0. This should have been fixed. Still investigating.
Flags: needinfo?(arthur.chen)
I could reproduce the issue on master with additional steps following the original STR. After the connection fail, restart the settings app and navigate to the panel for selecting network operators. The menu is missing.

The root cause is that when connection fails, we are not able to tell the current connected network type and cannot determine whether the operator menu is visible or not (the menu is for GSM only). A more robust solution would be determine the visibility of the menu based on the supported network type of each sim slot.

Comment 13

5 years ago
Triage: blocking, high user impact.
Assignee: nobody → arthur.chen
blocking-b2g: 2.1? → 2.1+
I spoke with CAF and its fine to fix this in 2.1 so i am switching the blocking flag.
blocking-b2g: 2.1+ → 2.2+
What the patch does is basically use the supported network type of each sim slot to determine the visibility of the menu when the current voice type is not available. EJ, could you help review the change? Thanks.
Attachment #8537729 - Flags: review?(ejchen)
Basically this patch looks nice to me, but there is one open question waiting for Anshul's feedback.

Let's wait his feedback on Github first and see whether we should update any details or not.
Anshul, please help to answer questions Arthur left on Github. Let me set ni? here to make sure you didn't miss them on Github ! Thanks :)
Flags: needinfo?(anshulj)

Comment 18

4 years ago
Phil, please provide your feedback.
Flags: needinfo?(anshulj) → needinfo?(pgravel)
(Reporter)

Comment 19

4 years ago
As stated in github, I believe the proposed solution is reasonable.
Flags: needinfo?(pgravel)
Comment on attachment 8537729 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26842

Thank all, r+ based on @pgravel's feedback.
Attachment #8537729 - Flags: review?(ejchen) → review+
Comment on attachment 8537729 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26842

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users may not be able to reconnect to the network
[Testing completed]: Manual tests completed
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8537729 - Flags: approval-gaia-v2.2?
Attachment #8537729 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
pgravel, can you please help us verify that this is fixed for you in 2.2 when you get a chance. Thanks!
Flags: needinfo?(pgravel)
(Reporter)

Comment 23

4 years ago
Works for me.
Flags: needinfo?(pgravel)
master: 07138e5c91e049b03e93a56c7f81f33143626c3d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This issue has been verified as fixed on Flame 3.0 and Flame 2.2

The user can chose a network type and toggle automatic selection after failing to connect to a network. 

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150123002505
Gaia: 237008137f6d72b9cad25ff4faff14ff2c40ac63
Gecko: be24dd482a83
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
This issue has been verified as fixed on Flame 3.0 and Flame 2.2

The user can chose a network type and toggle automatic selection after failing to connect to a network. 

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150123002505
Gaia: 237008137f6d72b9cad25ff4faff14ff2c40ac63
Gecko: be24dd482a83
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Fixing the above comment.
You need to log in before you can comment on or make changes to this bug.