TEST-UNEXPECTED-FAIL | addon-sdk/tests/test-loader.test invalid module not cached and throws everytime | throws on first invalid require

RESOLVED DUPLICATE of bug 1092477

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 1092477
4 years ago
4 years ago

People

(Reporter: erikvold, Assigned: erikvold)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

TEST-PASS | addon-sdk/tests/test-loader.test exceptions in modules | this test module is next in the stack
TEST-END | addon-sdk/tests/test-loader.test exceptions in modules
TEST-START | addon-sdk/tests/test-loader.test invalid module not cached and throws everytime
TEST-UNEXPECTED-FAIL | addon-sdk/tests/test-loader.test invalid module not cached and throws everytime | throws on first invalid require - "Module `not-found` is not found at resource://522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack/addon-sdk/tests/fixtures/loader/missing-twice/not-found.js" == undefined
TEST-INFO | Traceback (most recent call last):
  File "resource://gre/modules/Promise-backend.js", line 691, in this.PromiseWalker.scheduleWalkerLoop/<
    DOMPromise.resolve().then(() => this.walkerLoop());
  File "resource://gre/modules/Promise-backend.js", line 749, in this.PromiseWalker.walkerLoop
    this.handlers.shift().process();
  File "resource://gre/modules/Promise-backend.js", line 870, in Handler.prototype.process
    nextValue = this.onResolve.call(undefined, nextValue);
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 505, in startMany/runNextTest/<
    self.start({test: test, onDone: runNextTest});
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 542, in start
    this.test.testFunction(this);
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/test.js", line 76, in null
    test(assert);
  File "resource://522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack/addon-sdk/tests/test-loader.js", line 143, in exports["test invalid module not cached and throws everytime"]
    assert.equal(firstError.message, "Module `not-found` is not found at " +
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/test/assert.js", line 123, in equal
    this.fail({
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/test/assert.js", line 88, in fail
    this._log.fail(message);
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/deprecated/unit-test.js", line 98, in fail
    this.console.testMessage(false, false, this.test.name, message);
  File "resource://extensions.modules.522eac31-0f1a-4fe2-8d55-c3566a238a32-at-jetpack.commonjs.path/sdk/test/harness.js", line 546, in testMessage
    this.trace();
TEST-UNEXPECTED-FAIL | addon-sdk/tests/test-loader.test invalid module not cached and throws everytime | first error is on line 7 - 8 == undefined
TEST-INFO | Traceback (most recent call last):
  File "resource://gre/modules/Promise-backend.js", line 691, in this.PromiseWalker.scheduleWalkerLoop/<
    DOMPromise.resolve().then(() => this
Depends on: 1092477
Assignee: nobody → evold
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092477
You need to log in before you can comment on or make changes to this bug.