site (webmaker.org) is blank if cookies are blocked

RESOLVED WORKSFORME

Status

Webmaker
General
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Gavin Cannizzaro, Unassigned)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141106120505

Steps to reproduce:

Go to webmaker.org in a browser that refuses it cookies.

In Firefox, you can do this by going to Tools > Options > Privacy and unchecking "Accept cookies from sites" before loading the page.  This option exists to protect people from, e.g. tracking by ad networks, and it is offered by all major browsers.


Actual results:

A blank page.


Expected results:

The content comprising webmaker.org.

Comment 1

4 years ago
Created attachment 8527257 [details]
WebMaker.org with blocked Cookies

Comment 2

4 years ago
Created attachment 8527258 [details]
Console dump 1/3

Comment 3

4 years ago
Created attachment 8527259 [details]
2/3 Console dump

Comment 4

4 years ago
Created attachment 8527260 [details]
Console dump 3/3

Comment 5

4 years ago
To get a better idea of what is happening, I attached some screenshots.

The page is not blank per se, but it looks like a template failed to parse to me.
I've tested this and it seems to be working fine. Please file a bug here if it still doesn't work for you http://github.com/mozilla/webmaker.org
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.