[FFOS2.0][Woodduck][Calender] "Wrong login and /or password." will pop up if add a Yahoo account from Calendar settings.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Calendar
P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned, NeedInfo)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:
 "Wrong login and /or password." will pop up after a while.
 因为Yahoo账号的配置比较特殊,默认的是错的,而日历设置中不能手动更改配置,所以Yahoo账号无法正常添加。
 
 Soul 3.5 FF存在同样的问题
 
 周琴0752-2639384(61384)
 
  REPRODUCING PROCEDURES:
 1. Enter Calendar -> Options -> Settings Add Account,
 2. Select Yahoo! and input the correct account and password, touch "Save",
 3. Check the behavior of Test Device.
 
  EXPECTED BEHAVIOUR:
 It can login successfully or delete the Yahoo account in Calendar account settings.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

4 years ago
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: 1054172, 1080481
Flags: needinfo?(fan.luo)
Keywords: qawanted
Created attachment 8522769 [details]
Verify.png

The bug can be reproed on Woodduck 2.0M and Flame 2.0/2.1/2.2

Attached: Verify.png & logcatVerify.txt
Found time: 4:20pm.
Rate: 100%

------------------
Woodduck:
Gaia-Rev        ee5cf148b4c546beea9bfb799d2a3ee62074957d
Gecko-Rev       73601b71861cbc2f180c4d2653cec3e9fbb39db5
Build-ID        20141114050313
Version         32.0
Device-Name     soul35
FW-Release      4.4.2
FW-Incremental  1415912730
FW-Date         Fri Nov 14 05:05:53 CST 2014
---------------------------
Flame 2.0:
Gaia-Rev        ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e21bf45e6c44
Build-ID        20141113000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141113.033816
FW-Date         Thu Nov 13 03:38:27 EST 2014
Bootloader      L1TC00011880
----------------------------
Flame2.1:
Gaia-Rev        569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d188e92aa5a6
Build-ID        20141113001200
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141113.081909
FW-Date         Thu Nov 13 08:19:20 EST 2014
Bootloader      L1TC00011880
----------------------------
Flame2.2 build:
Gaia-Rev        be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ab137ddd3746
Build-ID        20141113040205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141113.072636
FW-Date         Thu Nov 13 07:26:47 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
Yahoo account can login successfully on Mail app, can't login on calendar.
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Keywords: qawanted

Updated

4 years ago
See Also: → bug 974554

Updated

4 years ago
blocking-b2g: --- → 2.0M?

Comment 5

4 years ago
(In reply to Norry.L.F from comment #4)
> Yahoo account can login successfully on Mail app, can't login on calendar.

Hi! David,

Since device team doesn't have team member who can cover calendar app issue and this bug also affects 2.0, 2.1 and 2.2, could you have someone to handle this case? 
This looks similar to bug 974554. Thanks

--
Keven
Flags: needinfo?(dscravaglieri)
Dylan, I think it would be more than welcome to fix that, thx
Flags: needinfo?(dscravaglieri) → needinfo?(doliver)
I don't really see the similarity to bug 974554 -- this doesn't appear to be a data sync issue. As far as I read this bug, you are unable to login with Yahoo at all, is that correct? 

I am unable to reproduce on 2.2. I can login to a Yahoo account and sync events bi-directionally. 

Miller, do you see anything interesting in the logs?
Flags: needinfo?(doliver) → needinfo?(mmedeiros)

Comment 8

4 years ago
(In reply to Dylan Oliver [:doliver] from comment #7)
> I don't really see the similarity to bug 974554 -- this doesn't appear to be
> a data sync issue. As far as I read this bug, you are unable to login with
> Yahoo at all, is that correct? 
> 
> I am unable to reproduce on 2.2. I can login to a Yahoo account and sync
> events bi-directionally. 
> 
> Miller, do you see anything interesting in the logs?

Hi Dylan, Per comment 4. Norry can login successfully on Mail app, but can't login on calendar. 
Did you observe the same issue? Thanks!
Flags: needinfo?(doliver)
the log doesn't give any clue to me and I was able to log into my yahoo account multiple times.

Does NOT reproduce on Flame 2.1

Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0

Does NOT reproduce on Flame 2.2

Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1

maybe it was something temporary on yahoo or maybe something that changed on Gecko the past weeks. can you confirm issue still reproduces for you? the calendar log on 2.2 is more verbose so I would start with that.
Flags: needinfo?(mmedeiros)
Flags: needinfo?(fan.luo)
Flags: needinfo?(doliver)

Comment 10

4 years ago
Hi Norry,
Please attach video. Thanks!
Created attachment 8530114 [details]
Verify1.mp4

Attach video and logcat1.txt of Flame 2.2, and this bug still also exists on Woodduck 2.0m and Flame 2.0/2.1

Rate: 100%
Found time: around 9:05am

Woodduck build:
Gaia-Rev        8e17537f9e6d02b7271d92134671414d1fb88386
Gecko-Rev       71be912cc4fedd423869ad9dce72880de170851f
Build-ID        20141128050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1417122322
FW-Date         Fri Nov 28 05:05:45 CST 2014
------------------
Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141127000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.034818
FW-Date         Thu Nov 27 03:48:29 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.1 build:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.035005
FW-Date         Thu Nov 27 03:50:16 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.2 build:
Gaia-Rev        80bc1445959db79e9d2e947cc56e1eb7b0d3d0f0
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/7dfad34d265b
Build-ID        20141127040204
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141127.074535
FW-Date         Thu Nov 27 07:45:46 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
I was able to reproduce this today 3 out of 20 tries.. the weird thing is that after I logged out from my yahoo account on the desktop to make sure I was using the correct login/password I was able to login all the times (only the first 3 failed).

Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
Device-Name     flame

the PROPFIND request returned 401 (unauthorized), and I'm sure the request headers were correct (same values as when it succeeds). no idea what is going on but it's probably on Yahoo's side.
I just saw an email from yahoo telling that I was trying to access my account from an unknown device in the US (I'm usually in Brazil); so I guess that after I logged in with my laptop they recognized that the location/IP matched and unlocked my account.. maybe that is the same thing that you are experiencing.

If you are able to reproduce please copy the response headers to me so that we can see if there is anything that gives us enough information to maybe display a better error message.

Comment 15

4 years ago
Hi Norry,
Can you check whether you can unlock Yahoo account as mentioned in comment 13 and comment 14?
If so, please also provide new log and check whether the behavior is correct now. Thanks!
Flags: needinfo?(fan.luo)
Hi Josh,
I can unlock Yahoo account as mentioned in comment 13 and comment 14, but now these accounts are all unlocked, and I have no account to repro bug, so I can't collected the log, I will try to repro it and collect log again tomorrow.
Flags: needinfo?(fan.luo)
Created attachment 8541539 [details]
Woodduck2.0 logcat

I have unlocked Yahoo account as mentioned in comment 13 and comment 14 on Woodduck 2.0/Flame 2.0/2.1/2.2.
See attachment: Woodduck2.0_logcat_1127.txt & Woodduck2.0_video.MP4
Repro time: 23:27~23:30	
Occurrence rate: 2/2

Woodduck 2.0 build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0

Flame 2.0 build:
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141225000210
Version         32.0

Flame 2.1build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0

Flame 2.2 build:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Created attachment 8541545 [details]
Woodduck2.0 video
Hi Josh,
Could you please help with it, thanks!
Flags: needinfo?(jocheng)

Comment 20

4 years ago
Hi Reporter,
Can you try procedure per comment 14 and comment 16 to unlock your Yahoo account and try again? We confirmed the problem can be solved after it. You can check video 18.

Updated

4 years ago
Blocks: 1107999
No longer blocks: 1080481
blocking-b2g: 2.0M? → ---
Flags: needinfo?(jocheng) → needinfo?(sync-1)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.