[Midori 2.0][Power consumption][Music] Standby current is 34mA (screen off) after pause music.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
P2
normal
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
FireFox OS V2.0
 
 mozilla build id:20141019000201
 
 DEFECT DESCRIPTION:
  Standby current is 34mA (screen off) after pause music.
 
  REPRODUCING PROCEDURES:
  1. Enter "Music"-> select a song to play;
  2. Pause it, make screen off, take measure current, it is 34mA.--KO
 
 
  EXPECTED BEHAVIOUR:
  Standby current should be<5mA.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Power consumption problem is a serious problem, please support. thanks
blocking-b2g: --- → 2.0?
Flags: needinfo?(wehuang)
Please add logcat and the information of “this is reproducible in 1.3 SW or not” for this issue.
Flags: needinfo?(sync-1)

Comment 3

4 years ago
de-tag candidate as rend to be device specific, as this is tested in Flame in other issue and not repro.
Flags: needinfo?(wehuang)

Comment 4

4 years ago
[Triage] de-tag as tends to be device-specific.
blocking-b2g: 2.0? → ---

Comment 5

4 years ago
(In reply to Wesly Huang from comment #4)
> [Triage] de-tag as tends to be device-specific.

hi, wesly, I think that this bug may be having the same issue with bug 1098682
as talked in that bug, blake said should not use pause to save power consumption, and should apply dormant mechanism.
As we debugged on this bug, we got to the same result that while music paused, some audio resources is not released, that's the reason why standby power consumption raised. It's obviously not device-specific.
Flags: needinfo?(wehuang)

Comment 6

4 years ago
Hi Wesly,

It was also reproduced on Flame2.0, so I think it's a common issue, at least TCL 8210 platform issue.

We are investigating internally,  need mozilla to check on Flame2.0 at the same time.

Thanks for your understanding.

Updated

4 years ago
Flags: needinfo?(sync-1)
At fist, this problem should be handle as a hw codec's problem. On caf, OMXCocec::pause() should reduce power consumption.
diego, can you comment to this bug?
Flags: needinfo?(dwilson)
Bhargav,

We test for this, don't we?
Flags: needinfo?(dwilson) → needinfo?(bhargavg1)

Comment 10

4 years ago
See Bug 994881 for more info on how the pause is handled
Flags: needinfo?(bhargavg1)

Comment 12

4 years ago
It seems in gecko/content/media/omx/AudioOffloadPlayer.cpp##AudioOffloadPlayer::Pause()
that the power consumption will reduce after a OFFLOAD_PAUSE_MAX_MSECS timer
that is 60s.

So I think it's designed to be so.

Updated

4 years ago
Flags: needinfo?(wehuang)
Setting NI? for myself to see if this is still happening.
Flags: needinfo?(jdarcangelo)

Updated

2 years ago
Blocks: 1258639
Clearing old NI? requests. Please re-flag me if necessary. Thanks
Flags: needinfo?(jdarcangelo)

Comment 15

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.