Input form will only print upper case letters, no matter if SHIFT or CAPSLOCK or pressed or not

VERIFIED DUPLICATE of bug 150341

Status

()

P2
minor
VERIFIED DUPLICATE of bug 150341
17 years ago
16 years ago

People

(Reporter: sebastian, Assigned: rods)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

This is the site of a German computer zine. With this popup window one can mail
articles and recommendations to a friend. If you try to enter data into the
forms you'll recognize that all input is tranformed to upper case. Especially
annoying with the German Umlaut ß (ß) where two s will be echoed. If you
send URLs they become invalid, of course. 

Reproducible: Always
Steps to Reproduce:
1. Enter text into the provided forms
2. See the text becoming upper cased
3. This is it.

Expected Results:  ;-) It should echo upper case when SHIFT or CAPSLOCK is
pressed only. At least this is what IE does.
Over to HTML form controls.  Site uses text-transform:uppercase.  Should this
apply to form controls?
Assignee: rogerl → rods
Status: UNCONFIRMED → NEW
Component: Javascript Engine → HTML Form Controls
Ever confirmed: true
QA Contact: pschwartau → madhur
(Assignee)

Comment 2

17 years ago
Need a reduced test case that includes the style sheet.
(Reporter)

Comment 3

17 years ago
Created attachment 57745 [details]
Contains the original HTML file, a reduced test case, and the css file.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2
(Assignee)

Updated

17 years ago
Priority: -- → P2
Target Milestone: mozilla1.2 → Future

Updated

17 years ago
QA Contact: madhur → tpreston
Boris, didn't you just fix this?
Yes.  Dupping forward to fixed bug, sorry...

*** This bug has been marked as a duplicate of 150341 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Thanks for duping that.  I so could not find that bug by its summary.

Verified dupe of 150341.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.