Closed Bug 1098895 Opened 5 years ago Closed 5 years ago

Images flicker(appear/disappear) on Aurora35.0a2.

Categories

(Core :: Layout, defect)

35 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox34 --- unaffected
firefox35 + verified
firefox36 --- verified

People

(Reporter: alice0775, Assigned: nical)

References

Details

(Keywords: regression)

[Tracking Requested - why for this release]: Regression 

Images flicker(appear/disappear) on Aurora35.0a2. 
But, it is not reproduced on Beta34 and Nightly36.0a1.

STR
Open http://ie.microsoft.com/testdrive/Performance/FlyingImages/Default.html


Note:
The other bug (images cut off) exists on Nightly36.0a1.
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/697c4b245de0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20141003100802
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d84db3f0c1ab
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20141003103345
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=697c4b245de0&tochange=d84db3f0c1ab
Regressed by:
d84db3f0c1ab	Nicolas Silva — Bug 1073113 - make D3D11 image layers double buffered. r=mattwoodrow
Blocks: 1073113
Fixed range(m-i)
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fff578fc740a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141020064511
Fixed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9774579c63f1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141020065111
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fff578fc740a&tochange=9774579c63f1
Flags: needinfo?(nical.bugzilla)
See Also: → 1098958
Can you still reproduce this on beta? I can't reproduce locally with D2D and cairo for drawing, and for compositing with D3D11 and basic layers.

I can reproduce Bug 1098958 but on nightly rather than beta.
Flags: needinfo?(alice0775)
Images flicker(appear/disappear) on Aurora35.0a2. 
But, it is not reproduced on Beta34 and Nightly36.0a1.
Flags: needinfo?(alice0775)
(In reply to Alice0775 White from comment #4)
> Images flicker(appear/disappear) on Aurora35.0a2. 
> But, it is not reproduced on Beta34 and Nightly36.0a1.

Sorry I misread the first comment. I can indeed reproduce on aurora, and I confirmed that backing out the ImageClient patch fixes the issue. It's not clear what actually fixed it in nightly, but at this point I am thinking of just simplifying the ImageClient code to remove the double-buffered code path which would fix this (Bug 1101552).
Flags: needinfo?(nical.bugzilla)
Assignee: nobody → nical.bugzilla
Depends on: 1101552
Fixed by the uplift of bug 1101552.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify+
Reproduced the original flickering with Nightly from October 8th. The issue no longer showed with Firefox 35 Beta 5 (BuildID=20141218174327) and the latest Firefox 36 Aurora (BuildID=20141222004004) on Windows 7 x64, Mac OS X 10.9.5 and Ubuntu 14.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.