Closed Bug 1098947 Opened 5 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/tests/mailnews/db/gloda/test/unit/test_index_junk_imap_online.js | xpcshell return code: -11

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: hiro, Assigned: jandem)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

PROCESS | 18168 | Assertion failure: this->is<T>(), at /builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/js/src/jsobj.h:744

PROCESS-CRASH | /builds/slave/test/build/tests/xpcshell/tests/mailnews/db/gloda/test/unit/test_index_junk_imap_online.js | application crashed [@ JSObject::as<js::ClonedBlockObject>] 


Caused by https://hg.mozilla.org/mozilla-central/rev/8792056f152c
Keywords: regression
Moving to JS since this appears to be a JIT failure.
Component: Database → JavaScript Engine: JIT
Product: MailNews Core → Core
Attached patch PatchSplinter Review
Sorry for breaking the Thunderbird tests! I'm glad they caught this bug though.

Shu, the problem was that we were passing |pc| instead of |unwoundScopeToPc| to DebugEpilogue. UnwindScope then tried to unwind an already-unwound block object and asserted.
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Attachment #8523415 - Flags: review?(shu)
I guess the tests are also proud of themselves.
Attachment #8523415 - Flags: review?(shu) → review+
https://hg.mozilla.org/mozilla-central/rev/cda8cad77b9f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.