[camera][gaia] Flash will be still on when camera switch from video mode to picture mode

RESOLVED FIXED

Status

P5
trivial
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jinchao.wang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
[gaia][camera]flash will be still on when camera switch from video mode to picture mode

Repro Steps:
1.open camera
2.click HUD-flash to auto(Flash Auto)
3.switch to video mode
4.click HUD-flash to torch(Flash On)
5.switch back to picture mode

Actual:
The flashModesPicture is auto, but flash is still on.

Expected:
flash should off in Picture mode.

Repro frequency: 
5/5, 100%
(Reporter)

Updated

4 years ago
Priority: -- → P3
(Reporter)

Updated

4 years ago
Priority: P3 → P1
I am unable to reproduce this on a recent Flame b2g-inbound/master build: the flash mode switches back to 'auto' when switching back to picture mode.

Can you tell us what build you are running?
Flags: needinfo?(jinchao.wang)
Summary: [gaia][camera]flash will be still on when camera switch from video mode to picture mode → [camera][gaia] Flash will be still on when camera switch from video mode to picture mode
(Reporter)

Comment 2

4 years ago
Created attachment 8523642 [details]
issue_video

I found this issue on SPRD phone.
Flags: needinfo?(jinchao.wang)
(Reporter)

Comment 3

4 years ago
It‘s our side code’s problem。
Severity: major → trivial
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Priority: P1 → P5
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.