Autocomplete popup displays "moz-action:searchengine,..." for keyword searches while pressing Shift

RESOLVED FIXED in Firefox 37

Status

()

Firefox
Location Bar
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: dao, Assigned: Unfocused)

Tracking

Trunk
Firefox 37
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
STR:
- add a keyword for a search engine
- type the keyword plus some search term in the location bar
- hit the down arrow key to select the autocomplete item for the keyword search
- press Shift
(Reporter)

Updated

3 years ago
Summary: Autocomplete popup displays moz-action:searchengine,... for keyword searches while pressing Shift → Autocomplete popup displays "moz-action:searchengine,..." for keyword searches while pressing Shift
should be tested again after bug 1070778.
Depends on: 1070778
Not fixed by bug 1070778, so taking this now since it's enough to block shipping unifiedcomplete.
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
No longer depends on: 1070778
Flags: qe-verify-
Flags: firefox-backlog+
Hi Blair, can you provide a point value.
Iteration: --- → 36.3
Flags: needinfo?(bmcbride)
Oops
Points: --- → 3
Flags: needinfo?(bmcbride)

Updated

3 years ago
Iteration: 36.3 → 37.1
Created attachment 8529396 [details] [diff] [review]
Patch v1

Dependent on the changes in head.js done in bug 1073339.
Attachment #8529396 - Flags: review?(mak77)

Updated

3 years ago
Depends on: 1073339
Comment on attachment 8529396 [details] [diff] [review]
Patch v1

Review of attachment 8529396 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not sure why but it doesn't seem to work for me, I tried a couple rebuilds but nothing..

when I move to a switch to tab entry and I press shift, the switch to tab text should be replaced by the url but that doesn't happen.
Attachment #8529396 - Flags: review?(mak77)
Created attachment 8530821 [details] [diff] [review]
Patch v1.1

Could you try again?

autocomplete.xml got bitrotten, am wondering if that was your issue. This patch is the same as the previous, just rebased.
Attachment #8529396 - Attachment is obsolete: true
Attachment #8530821 - Flags: review?(mak77)
Comment on attachment 8530821 [details] [diff] [review]
Patch v1.1

Review of attachment 8530821 [details] [diff] [review]:
-----------------------------------------------------------------

yeah now it works. sorry for the delay.

::: toolkit/content/widgets/autocomplete.xml
@@ +1608,5 @@
>              this.setAttribute("actiontype", action.type);
>  
>              if (action.type == "switchtab") {
> +            this.classList.add("overridable-action");
> +            displayUrl = action.params.url;

splinter doesn't show the right indentation here, please check.
Attachment #8530821 - Flags: review?(mak77) → review+
Whiteboard: [blocked on bug 1073339 landing]

Updated

3 years ago
Iteration: 37.1 → 37.2

Updated

3 years ago
Whiteboard: [blocked on bug 1073339 landing]

Updated

3 years ago
Iteration: 37.2 → 37.3
https://hg.mozilla.org/integration/fx-team/rev/f9d665c7c667
https://hg.mozilla.org/mozilla-central/rev/f9d665c7c667
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37

Comment 11

10 months ago
This bug affects me on Firefox 48 for Linux.

Comment 12

10 months ago
(for all keyword completions, not just when shift is pressed)

Comment 13

10 months ago
(In reply to Hide my Email from comment #11)
> This bug affects me on Firefox 48 for Linux.

please check in Safe mode, cause your issue may be caused by an add-on.
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Comment 14

10 months ago
Ah, it's not exactly fault of an extension but some internal change of Firefox that broke keyword previews when the bookmark URL starts with a pseudo-protocol like private: .

I'm waiting for the new version of Private Tab to be reviewed to test if this still happens (https://addons.mozilla.org/firefox/addon/private-tab/versions/).
You need to log in before you can comment on or make changes to this bug.