Clicking on an anchor in a webpage makes title not pushed back to the statusbar

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System::Browser Chrome
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: gerard, Assigned: cwiiis)

Tracking

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Scrolling in a web page pushed the title of the page inside the statusbar. But after clicking a link to an anchor on the same page, it does not work and title is "blocked" and not pushed to the statusbar when scrolling.

STR:
 0. Open Browser
 1. Browse to http://www.w3.org/TR/html401/struct/links.html
 2. Click on a link in the menu of the page

Expected:
 When I scroll, the title of the page is pushed to statusbar

Actual:
 Title stays big.
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 1

3 years ago
Can reproduce - I suspect going to an anchor counts as a location-change, but we don't get a document size event after that.

We could solve this either by checking the size on scroll-change (probably a bad idea) or filtering out anchor changes... I'll do the latter.

I expect this affects 2.1... I don't suppose it's a blocker, but as I suspect the fix will be quite simple, I'll request when it's done.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Flags: needinfo?(chrislord.net)
(Assignee)

Comment 2

3 years ago
Created attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing
Attachment #8523023 - Flags: review?(etienne)
(Assignee)

Comment 3

3 years ago
Just a note; this can't easily be tested via marionette because scrollgrab doesn't work without apz (and thus the rocketbar can never be collapsed).
Whiteboard: [systemsfe]
Comment on attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing

Looking good! But we should cover this with a small unit test (we already have some around this [1]), making sure the containerElement keeps the "scrollable" class.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/test/unit/app_chrome_test.js#L201-220
Attachment #8523023 - Flags: review?(etienne)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing

Stopped being lazy and added unit test :)
Attachment #8523023 - Flags: review?(etienne)
Comment on attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing

Thanks!
Attachment #8523023 - Flags: review?(etienne) → review+
(Assignee)

Comment 7

3 years ago
Merged: https://github.com/mozilla-b2g/gaia/commit/fccfaa85efd7712a8d72905b0845a5d0290269d3
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Rocketbar will become permanently visible after navigating to an anchor on the same page, until the user navigates to another URL.
[User impact] if declined: Confusing behaviour after visiting an anchor on the same page (common in pages that have indices/appendices, but not perhaps that common in general mobile web browsing).
[Testing completed]: Tested locally, has unit test
[Risk to taking this patch] (and alternatives if risky): Low risk.
[String changes made]: None

This isn't a blocker and it's not the end of the world if we don't uplift this, but I believe it to be low risk and it's nice to fix bugs that can be so easily encountered.
Attachment #8523023 - Flags: approval-gaia-v2.1?
blocking-b2g: 2.2? → ---
Comment on attachment 8523023 [details] [review]
Fix anchor links breaking rocketbar collapsing

Chris, was really on the fence for this one but given the test coverage and that the users will see this often, uplifting to avoid the annoyance :)
Attachment #8523023 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
https://github.com/mozilla-b2g/gaia/commit/f211a1b6cb136c944f2e7b17650ae4c541bd512f
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.1 S9 (21Nov)
Hi Alex,
Can you provide the bug video for me? Thanks.
Flags: needinfo?(lissyx+mozillians)
(Reporter)

Comment 12

3 years ago
(In reply to Lance from comment #11)
> Hi Alex,
> Can you provide the bug video for me? Thanks.

No, why do you need a video ? STRs are not working for you ?
Flags: needinfo?(lissyx+mozillians)
This issue has been verified successfully on Flame 2.1.
See attachment: 1059.MP4
Reproducing rate: 0/5

Step:
 1.Launch Browser.
 2.Browse to http://www.w3.org/TR/html401/struct/links.html.
 3.Slide the page, then tap a link in the menu of the page.
 4.Slide the page again.

Actual result:
When I scroll, the title of the page is pushed to statusbar.

Flame 2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141130.034738
FW-Date         Sun Nov 30 03:47:49 EST 2014
Bootloader      L1TC00011880
status-b2g-v2.1: fixed → verified
Status: RESOLVED → VERIFIED
Created attachment 8530722 [details]
1059.MP4
You need to log in before you can comment on or make changes to this bug.