Plain window frame and black bars and/or graphics artifacts when using OS fullscreen on page with video

RESOLVED DUPLICATE of bug 1086985

Status

()

RESOLVED DUPLICATE of bug 1086985
4 years ago
4 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox34 affected, firefox35 unaffected, firefox36 unaffected)

Details

(Reporter)

Description

4 years ago
Broken on beta (clean profile, too), fixed on trunk and devedition.


STR:

1. Open https://bug1099052.bugzilla.mozilla.org/attachment.cgi?id=8522893
2. Hit F11


This produces a flickering plain window frame (as if maximized/restored instead of fullscreen), and some black bars at the top and bottom of the screen, on Windows.

On my retina MBP (using the fullscreen button, still on OS X 10.9), I see graphics artifacts from other sites open in tabs (!?) on the bottom of the screen, but no blackness.

Going to try to figure out when this got fixed on trunk to see if we can still uplift something...

Note that this reproduces 100% of the time for me, but no such weird effects happen on other pages that I try to fullscreen.

about:support for my Windows machine:

Adapter Description	NVIDIA Quadro 600
Adapter Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	1024
Device ID	0x0df8
Direct2D Enabled	true
DirectWrite Enabled	true (6.3.9600.17111)
Driver Date	8-29-2013
Driver Version	9.18.13.2702
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	083510de
Vendor ID	0x10de
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA Quadro 600 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(Reporter)

Comment 1

4 years ago
This was broken in 34b1 but never broken while on Nightly, AFAICT. :-(
(Reporter)

Comment 2

4 years ago
This regressed on aurora between 10-11 and 10-12, just before beta uplift:

http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=f6ccaf5a4b15&tochange=e96a7a4f3bbe

which was bug 1062100.

Good news, though: latest beta tinderbox builds have this fixed, so presumably this is a dupe of bug 1086985
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1086985
You need to log in before you can comment on or make changes to this bug.