[B2G][Flame][Browser] Browser displays white screen, address bar and add tab button are not shown

RESOLVED FIXED

Status

Firefox OS
Gaia::Browser
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Sridhar A, Assigned: yifan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0M affected)

Details

(Whiteboard: [LibGLA,TD130138,QE5,A])

Attachments

(10 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141113030201

Steps to reproduce:

Device: Flame
OS Version: 2.0.0.0
Git Commit Info: 2014-10-10 07:25:55
                       8c5c956e

Precondition : Set up data connectivity

1. Open browser and got to the home page of Mozilla (https://www.mozilla.org)
2. After the home page is opened, select address bar and type https://support.mozilla.org and select go button.
3. While that page is loading, scroll down the current page and select the add tab button.
4. Tabs window is now opened


Actual results:

After page loading is done, browser displays a blank white screen, address bar and add tab button are not shown.

Press home button and open browser again, it still displays white screen. 



Expected results:

Browser shouldn't display blank white screen, it should show the address bar and add tab button.
(Reporter)

Comment 1

3 years ago
Created attachment 8522948 [details]
Browser_WhiteScreen_Issue.zip
(Reporter)

Comment 2

3 years ago
Created attachment 8522950 [details]
Browser_WhiteScreen_Issue.z01
(Reporter)

Comment 3

3 years ago
Created attachment 8522951 [details]
Browser_WhiteScreen_Issue.z02
(Reporter)

Comment 4

3 years ago
Created attachment 8522952 [details]
Browser_WhiteScreen_Issue.z03
(Reporter)

Comment 5

3 years ago
Created attachment 8522953 [details]
Browser_WhiteScreen_Issue.z04
(Reporter)

Comment 6

3 years ago
Created attachment 8522955 [details]
Browser_WhiteScreen_Issue.z05
(Reporter)

Comment 7

3 years ago
Created attachment 8522956 [details]
Browser_WhiteScreen_Issue.z06
(Reporter)

Comment 8

3 years ago
Created attachment 8522957 [details]
Browser_WhiteScreen_Issue.z07
(Reporter)

Comment 9

3 years ago
Created attachment 8522959 [details]
Browser_WhiteScreen_Issue.z08
(Reporter)

Comment 10

3 years ago
Attached video to reproduce this issue. As the video file is large I have split and attached the files. Kindly download all the attached files and extract using winzip to watch the video.
(Reporter)

Updated

3 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [LibGLA,TD130138,QE5,A]
(Reporter)

Updated

3 years ago
Flags: needinfo?(ryang)
Hi Yifan, would you please look into the issue ? 
Thank you very much!
Flags: needinfo?(ryang) → needinfo?(yliao)
(Assignee)

Updated

3 years ago
Assignee: nobody → yliao
Flags: needinfo?(yliao)
(Assignee)

Comment 12

3 years ago
The root cause is: after loaded mozilla.org and clicked support.mozilla.org in step 2, before the 'mozbrowserloadstart' event received, a couple 'mozbrowserasyncscroll' events are received because of step 3. 'mozbrowserasyncscroll' event will hide the address bar which in turn causes the white screen. Will come up with a patch shortly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 13

3 years ago
Created attachment 8524369 [details] [review]
pull request for v2.0

Sorry I was wrong about the root cause. It's because the 'mozbrowserloadend' event will call 'handleScroll' function using the current scrollTop, which is not needed when displaying tabs screen. 

The fix checks if the current screen is page screen in 'mozbrowserloadend' event handler.
Attachment #8524369 - Flags: review?(dale)
(Assignee)

Updated

3 years ago
status-b2g-v2.0M: --- → affected
Comment on attachment 8524369 [details] [review]
pull request for v2.0

This fix looks good, thanks
Attachment #8524369 - Flags: review?(dale) → review+
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.