Cannot launch rocketbar by tapping on upper left of statusbar

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
etienne
: review+
Details | Review
Reporter

Description

5 years ago
Build info
Gaia-Rev        1e300eac2e56d98ad51d414766d031db7d33221f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bbb68df450c2
Build-ID        20141114040205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

STR
1. Reboot the phone and wait until radio signal displays in status bar 
2. Activate airplane mode and wait until the status bar displays the airplane icon
3. Launch an app

Expected result
Airplane mode is still displayed in status bar.

Actual result
Status bar is frozen, airplane mode is not displayed. If you go back to the homescreen, the status bar is in the right state. See video for details: http://mzl.la/1v9jh4y

Repro rate: 6/6

Additional notes: Tested with 0, 1 or 2 SIMs. I reproduced the problem each time.
Reporter

Comment 1

5 years ago
[Blocking Requested - why for this release]: Visible regression that could block certification.
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
I've been experiencing this for several days at least, probably 2 weeks. Multiple devices: Nexus S, Desire Z, Xperia ZR, Flame.
blocking-b2g: 2.2? → 2.2+
Reporter

Comment 3

5 years ago
Fernando also saw that issue on a build from 11 days ago:
Gaia-Rev        1b974ce130eed3988ff5d012c7bd8431c4aba93b
Gecko-Rev       Can't get the revision.
Build-ID        20141106185342
Version         36.0a1
Device-Name     mako
FW-Release      4.4.2
FW-Incremental  eng.ferjm.20141106.124732
FW-Date         Thu Nov  6 12:47:51 CET 2014
Bootloader      MAKOZ30d
Are some people confusing this issue with bug 1091483 and its many offshoots?  Testing so far has shown that this specific issue is a gecko issue that actually began on 11-12-2014 in central.  I will have the inbound regression window shortly.
This issue seems to have been caused by bug 1044736

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141112123112
Gaia: 65ce58778f65c5b39d9e558e02417c9954d55d6e
Gecko: 7558d1677282
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141112125016
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 66cdb18f36da
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 65ce58778f65c5b39d9e558e02417c9954d55d6e
Gecko: 66cdb18f36da

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 65d593cdd9d88648045a30a63fc329b7bb5d340b
Gecko: 7558d1677282

Gecko Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7558d1677282&tochange=66cdb18f36da


B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141112031313
Gaia: c1f97d511b199998ce002d1c2c1fa78435687141
Gecko: e203b87d8ce3
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141112032814
Gaia: c1f97d511b199998ce002d1c2c1fa78435687141
Gecko: b1a6ecfca674
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: c1f97d511b199998ce002d1c2c1fa78435687141
Gecko: b1a6ecfca674

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: c1f97d511b199998ce002d1c2c1fa78435687141
Gecko: e203b87d8ce3

Gecko Pushlog: https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=e203b87d8ce3&tochange=b1a6ecfca674
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)

Updated

5 years ago
Blocks: 1077595
broken by bug 1044736 - Can you take a look Kan-Ru?
Blocks: 1044736
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kchen)
Adding ST keyword to this bug. Suggest backing out the bug that caused it, and having QA reverify when it is landed again.
Keywords: smoketest
Bug 1100615 may be related as well and is a blocker to using the Rocketbar.
Posted file Github PR
There was a bug preventing some events to be dispatch from the utility tray.
Etienne, what do you think of it?
Attachment #8524570 - Flags: review?(etienne)
Comment on attachment 8524570 [details] [review]
Github PR

r+ on the test, we need to figure out if the code change lands as part of bug 1098118 or here and make sure we don't mix things up :)
Attachment #8524570 - Flags: review?(etienne) → review+
(In reply to Etienne Segonzac (:etienne) from comment #10)
> we need to figure out if the code change lands as part of
> bug 1098118 or here and make sure we don't mix things up :)

I closed bug 1098118 since there were no tests with that patch and they already had a patch landed. Guillaume, let's make sure we are not causing the same Gip tests that caused it to get backed out [1].

1.) https://bugzilla.mozilla.org/show_bug.cgi?id=1098118#c8
Resolving as works-for-me since bug 1044736 was backed out.
https://bugzilla.mozilla.org/show_bug.cgi?id=1044736#c63

Results: Status Bar updates when toggling airplane mode from Notification Tray and transitioning into applications.
Repro Rate: 4/4

Environmental Variables:
----------------------------------------------
Device: Flame 2.2
BuildID: 20141118040205
Gaia: 4aee256937afe9db2520752650685ba61ce6097d
Gecko: 7913c9392c5f
Gonk: 
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
----------------------------------------------
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(pbylenga)
Resolution: --- → WORKSFORME
Let's keep this open, since launching rocketbar from statusbar is still not working, and :gmarty's patch here fixes that.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Status bar is not updated when you're in an app → Cannot launch rocketbar by tapping on upper left of statusbar
(In reply to Michael Henretty [:mhenretty] from comment #13)
> Let's keep this open, since launching rocketbar from statusbar is still not
> working, and :gmarty's patch here fixes that.

What patch? I wonder what was broken by bug 1044736
Flags: needinfo?(kchen)
(In reply to Kan-Ru Chen [:kanru] from comment #14)
> What patch? I wonder what was broken by bug 1044736

See comment 9. I don't think that part was broken by bug 1044736.

Comment 16

5 years ago
The test_system_notification_bar.py intermittent failure is not related to this patch, it will be resolved in bug 1101227.
Thanks Zac.
This patch landed in master as of https://github.com/mozilla-b2g/gaia/commit/b039ee0b5c51645184c2bd2de83b595b14a29c87
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Flags: needinfo?(pbylenga)

Updated

5 years ago
Blocks: 1101227

Comment 18

5 years ago
Verified the issue is fixed on 2.2 Master Flame

Rocketbar is can be launched and airplane mode doesn't change the state

"Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.