Closed Bug 1099175 Opened 5 years ago Closed 5 years ago

Intermittent test_conformance__textures__texture-npot.html | Expected failures: conformance/textures/texture-npot.html - expected FAIL

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- fixed
firefox38 --- fixed
firefox39 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: cbook, Assigned: gbrown)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Android 4.0 Panda fx-team opt test mochitest-gl

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=1196073&repo=fx-team

23:00:49 INFO - 657 INFO TEST-UNEXPECTED-PASS | /tests/dom/canvas/test/webgl-conformance/_wrappers/test_conformance__textures__texture-npot.html | Expected failures: conformance/textures/texture-npot.html - expected FAIL
It looks like this test has been an expected fail on Android 4.0 since at least 09-2014 (bug 1052240). It may have always infrequently passed, but seems to be passing more frequently in the last few weeks, making it #5 on this week's War on Orange. 

Best to skip it entirely on Android?
Attachment #8568628 - Flags: review?(jgilbert)
I happen to have solved a similar issue while working on Bug 1112164 (caused by a bug in my patches).  Have you tried to reproduce this issue with IonMonkey turned off?
I have not tried, but could. It might take some effort since this is an intermittent unexpected pass. I don't see mention of this test in bug 1112164. What would I be looking for? Do you expect the test to pass or fail with IonMonkey turned off?
Comment on attachment 8568628 [details] [diff] [review]
skip conformance/textures/texture-npot.html on android

Review of attachment 8568628 [details] [diff] [review]:
-----------------------------------------------------------------

This test is unlikely to ever fail separately on android, so skipping it should be fine.
Attachment #8568628 - Flags: review?(jgilbert) → review+
If you disable IonMonkey, then you would be using only the interpreter and baseline.  So the intermittent should disappear if this is a compilation issue.
It looks like the Android Opt build fails with --disable-ion: https://treeherder.mozilla.org/#/jobs?repo=try&revision=221c02b266fb
(In reply to Geoff Brown [:gbrown] from comment #112)
> It looks like the Android Opt build fails with --disable-ion:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=221c02b266fb

Yes, this is fixed by Bug 1138180.
https://hg.mozilla.org/mozilla-central/rev/dbf77bc52cc3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.