build fails with warnings-as-errors: FFmpegAudioDecoder.h:38:42: error: private field 'mConfig' is not used [-Werror,-Wunused-private-field]

RESOLVED DUPLICATE of bug 1098400

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1098400
3 years ago
3 years ago

People

(Reporter: keeler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

3:53.31 In file included from /home/keeler/mozilla-central/obj-x86_64-unknown-linux-gnu/dom/media/fmp4/ffmpeg/libav54/Unified_cpp_fmp4_ffmpeg_libav540.cpp:2:
 3:53.31 In file included from /home/keeler/mozilla-central/dom/media/fmp4/ffmpeg/libav54/../FFmpegAudioDecoder.cpp:10:
 3:53.31 /home/keeler/mozilla-central/dom/media/fmp4/ffmpeg/libav54/../FFmpegAudioDecoder.h:38:42: error: private field 'mConfig' is not used [-Werror,-Wunused-private-field]
 3:53.31   const mp4_demuxer::AudioDecoderConfig& mConfig;
Thanks for the report. Fix is on inbound waiting for merge.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1098400
You need to log in before you can comment on or make changes to this bug.