Break reftest into two chunks on linux32

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 5 obsolete attachments)

(Assignee)

Description

3 years ago
Debug reftest is often hiding the 7200 hard timeout on linux32 (bug 1080010).  Let's split this into two chunks, just for linux32.
(Assignee)

Comment 1

3 years ago
Created attachment 8523258 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

Let's try this out on cedar first
Attachment #8523258 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Assignee: nobody → jgriffin
(Assignee)

Comment 2

3 years ago
Builders added:
+ Ubuntu VM 12.04 cedar debug test reftest-1
+ Ubuntu VM 12.04 cedar debug test reftest-2
+ Ubuntu VM 12.04 cedar opt test reftest-1
+ Ubuntu VM 12.04 cedar opt test reftest-2

Comment 3

3 years ago
Comment on attachment 8523258 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

this fails to pass checkconfig as it will create identical cedar builder names generated from REFTEST_NO_IPC. I don't see where we do the chunking (e.g. --reftest-suite plain-chunked) and I think REFTEST_TWO_CHUNKS may be just a duplicate of REFTEST_NO_IPC. I could be grepping poorly.

side note, IIRC, we have chunking support setup for mochitest in mozharness but mozharness reftest config items might have to get similar love: http://mxr.mozilla.org/build/source/mozharness/configs/unittests/linux_unittest.py#56

finally, for bonus confusion, I know that armen is in the middle of putting the mozharness config + chunking logic in tree so I am not sure where the right place is to put the mozharness bits. You probably know more than me but I thought it may be worth pointing that out.
Attachment #8523258 - Flags: review?(jlund) → review-

Comment 4

3 years ago
(In reply to Jordan Lund (:jlund) from comment #3)
> Comment on attachment 8523258 [details] [diff] [review]
> Split reftest into two chunks on linux32 on cedar,

jgriffin: also, sorry for the delay; I was at aws re:invent all last week and only checked bugzilla sporadically.
(Assignee)

Comment 5

3 years ago
Created attachment 8524960 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

This fixes the duplicate name problem.  I'll submit a separate patch (or two) for the related mozharness/config work.
Attachment #8524960 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Attachment #8523258 - Attachment is obsolete: true
(Assignee)

Comment 6

3 years ago
Created attachment 8524966 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

Ah, missed one change.  Will post an in-tree config patch too, shortly.
Attachment #8524966 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Attachment #8524960 - Attachment is obsolete: true
Attachment #8524960 - Flags: review?(jlund)
(Assignee)

Comment 7

3 years ago
Created attachment 8524974 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

Sorry, last change not needed.  Specifying totalChunks in buildbot-configs causes it to pass --total-chunks and --think-chunk args to the mozharness script.  We don't need it in e.g., http://mxr.mozilla.org/build/source/mozharness/configs/unittests/linux_unittest.py#56.  The mochitest equivalent is plain-chunked; we don't use plain1 through plain5 (at least on trunk).  I'd guess this is leftover from some transition period.  For reftest, there are no additional args we need for chunked operation (like --chunk-by-dir for mochitest), so there's no need for an additional entry in all_reftest_suites.
Attachment #8524974 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Attachment #8524966 - Attachment is obsolete: true
Attachment #8524966 - Flags: review?(jlund)

Comment 8

3 years ago
Comment on attachment 8524974 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

Review of attachment 8524974 [details] [diff] [review]:
-----------------------------------------------------------------

oh sorry, I'm with you now. looks good :)
Attachment #8524974 - Flags: review?(jlund) → review+
(Assignee)

Comment 9

3 years ago
Comment on attachment 8524974 [details] [diff] [review]
Split reftest into two chunks on linux32 on cedar,

https://hg.mozilla.org/build/buildbot-configs/rev/4cefbd4f12be
Attachment #8524974 - Flags: checked-in+
(Assignee)

Comment 11

3 years ago
Running well on cedar, I'll make a patch to roll this out on trunk branches.
(Assignee)

Comment 12

3 years ago
Created attachment 8534596 [details] [diff] [review]
Break reftest into two chunks on linux32 on all branches,
Attachment #8534596 - Flags: review?(jlund)
(Assignee)

Comment 13

3 years ago
Builders added:
+ Ubuntu VM 12.04 ash debug test reftest-1
+ Ubuntu VM 12.04 ash debug test reftest-2
+ Ubuntu VM 12.04 ash opt test reftest-1
+ Ubuntu VM 12.04 ash opt test reftest-2
+ Ubuntu VM 12.04 b2g-inbound debug test reftest-1
+ Ubuntu VM 12.04 b2g-inbound debug test reftest-2
+ Ubuntu VM 12.04 b2g-inbound opt test reftest-1
+ Ubuntu VM 12.04 b2g-inbound opt test reftest-2
+ Ubuntu VM 12.04 b2g-inbound pgo test reftest-1
+ Ubuntu VM 12.04 b2g-inbound pgo test reftest-2
+ Ubuntu VM 12.04 cypress debug test reftest-1
+ Ubuntu VM 12.04 cypress debug test reftest-2
+ Ubuntu VM 12.04 cypress opt test reftest-1
+ Ubuntu VM 12.04 cypress opt test reftest-2
+ Ubuntu VM 12.04 elm debug test reftest-1
+ Ubuntu VM 12.04 elm debug test reftest-2
+ Ubuntu VM 12.04 elm opt test reftest-1
+ Ubuntu VM 12.04 elm opt test reftest-2
+ Ubuntu VM 12.04 fig debug test reftest-1
+ Ubuntu VM 12.04 fig debug test reftest-2
+ Ubuntu VM 12.04 fig opt test reftest-1
+ Ubuntu VM 12.04 fig opt test reftest-2
+ Ubuntu VM 12.04 fx-team debug test reftest-1
+ Ubuntu VM 12.04 fx-team debug test reftest-2
+ Ubuntu VM 12.04 fx-team opt test reftest-1
+ Ubuntu VM 12.04 fx-team opt test reftest-2
+ Ubuntu VM 12.04 fx-team pgo test reftest-1
+ Ubuntu VM 12.04 fx-team pgo test reftest-2
+ Ubuntu VM 12.04 gum debug test reftest-1
+ Ubuntu VM 12.04 gum debug test reftest-2
+ Ubuntu VM 12.04 gum opt test reftest-1
+ Ubuntu VM 12.04 gum opt test reftest-2
+ Ubuntu VM 12.04 gum pgo test reftest-1
+ Ubuntu VM 12.04 gum pgo test reftest-2
+ Ubuntu VM 12.04 jamun debug test reftest-1
+ Ubuntu VM 12.04 jamun debug test reftest-2
+ Ubuntu VM 12.04 jamun opt test reftest-1
+ Ubuntu VM 12.04 jamun opt test reftest-2
+ Ubuntu VM 12.04 maple debug test reftest-1
+ Ubuntu VM 12.04 maple debug test reftest-2
+ Ubuntu VM 12.04 maple opt test reftest-1
+ Ubuntu VM 12.04 maple opt test reftest-2
+ Ubuntu VM 12.04 mozilla-aurora debug test reftest-1
+ Ubuntu VM 12.04 mozilla-aurora debug test reftest-2
+ Ubuntu VM 12.04 mozilla-aurora opt test reftest-1
+ Ubuntu VM 12.04 mozilla-aurora opt test reftest-2
+ Ubuntu VM 12.04 mozilla-aurora pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-aurora pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g30_v1_4 debug test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g30_v1_4 debug test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g30_v1_4 opt test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g30_v1_4 opt test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g32_v2_0 debug test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g32_v2_0 debug test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g32_v2_0 opt test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g32_v2_0 opt test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g34_v2_1 debug test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g34_v2_1 debug test reftest-2
+ Ubuntu VM 12.04 mozilla-b2g34_v2_1 opt test reftest-1
+ Ubuntu VM 12.04 mozilla-b2g34_v2_1 opt test reftest-2
+ Ubuntu VM 12.04 mozilla-beta debug test reftest-1
+ Ubuntu VM 12.04 mozilla-beta debug test reftest-2
+ Ubuntu VM 12.04 mozilla-beta opt test reftest-1
+ Ubuntu VM 12.04 mozilla-beta opt test reftest-2
+ Ubuntu VM 12.04 mozilla-beta pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-beta pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-central debug test reftest-1
+ Ubuntu VM 12.04 mozilla-central debug test reftest-2
+ Ubuntu VM 12.04 mozilla-central opt test reftest-1
+ Ubuntu VM 12.04 mozilla-central opt test reftest-2
+ Ubuntu VM 12.04 mozilla-central pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-central pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-esr31 debug test reftest-1
+ Ubuntu VM 12.04 mozilla-esr31 debug test reftest-2
+ Ubuntu VM 12.04 mozilla-esr31 opt test reftest-1
+ Ubuntu VM 12.04 mozilla-esr31 opt test reftest-2
+ Ubuntu VM 12.04 mozilla-esr31 pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-esr31 pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound debug test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound debug test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound opt test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound opt test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-release debug test reftest-1
+ Ubuntu VM 12.04 mozilla-release debug test reftest-2
+ Ubuntu VM 12.04 mozilla-release opt test reftest-1
+ Ubuntu VM 12.04 mozilla-release opt test reftest-2
+ Ubuntu VM 12.04 mozilla-release pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-release pgo test reftest-2
+ Ubuntu VM 12.04 oak debug test reftest-1
+ Ubuntu VM 12.04 oak debug test reftest-2
+ Ubuntu VM 12.04 oak opt test reftest-1
+ Ubuntu VM 12.04 oak opt test reftest-2
+ Ubuntu VM 12.04 try debug test reftest-1
+ Ubuntu VM 12.04 try debug test reftest-2
+ Ubuntu VM 12.04 try opt test reftest-1
+ Ubuntu VM 12.04 try opt test reftest-2
+ Ubuntu VM 12.04 try pgo test reftest-1
+ Ubuntu VM 12.04 try pgo test reftest-2
+ Ubuntu VM 12.04 ux debug test reftest-1
+ Ubuntu VM 12.04 ux debug test reftest-2
+ Ubuntu VM 12.04 ux opt test reftest-1
+ Ubuntu VM 12.04 ux opt test reftest-2
Builders removed
- Ubuntu VM 12.04 ash debug test reftest
- Ubuntu VM 12.04 ash opt test reftest
- Ubuntu VM 12.04 b2g-inbound debug test reftest
- Ubuntu VM 12.04 b2g-inbound opt test reftest
- Ubuntu VM 12.04 b2g-inbound pgo test reftest
- Ubuntu VM 12.04 cypress debug test reftest
- Ubuntu VM 12.04 cypress opt test reftest
- Ubuntu VM 12.04 elm debug test reftest
- Ubuntu VM 12.04 elm opt test reftest
- Ubuntu VM 12.04 fig debug test reftest
- Ubuntu VM 12.04 fig opt test reftest
- Ubuntu VM 12.04 fx-team debug test reftest
- Ubuntu VM 12.04 fx-team opt test reftest
- Ubuntu VM 12.04 fx-team pgo test reftest
- Ubuntu VM 12.04 gum debug test reftest
- Ubuntu VM 12.04 gum opt test reftest
- Ubuntu VM 12.04 gum pgo test reftest
- Ubuntu VM 12.04 jamun debug test reftest
- Ubuntu VM 12.04 jamun opt test reftest
- Ubuntu VM 12.04 maple debug test reftest
- Ubuntu VM 12.04 maple opt test reftest
- Ubuntu VM 12.04 mozilla-aurora debug test reftest
- Ubuntu VM 12.04 mozilla-aurora opt test reftest
- Ubuntu VM 12.04 mozilla-aurora pgo test reftest
- Ubuntu VM 12.04 mozilla-b2g30_v1_4 debug test reftest
- Ubuntu VM 12.04 mozilla-b2g30_v1_4 opt test reftest
- Ubuntu VM 12.04 mozilla-b2g32_v2_0 debug test reftest
- Ubuntu VM 12.04 mozilla-b2g32_v2_0 opt test reftest
- Ubuntu VM 12.04 mozilla-b2g34_v2_1 debug test reftest
- Ubuntu VM 12.04 mozilla-b2g34_v2_1 opt test reftest
- Ubuntu VM 12.04 mozilla-beta debug test reftest
- Ubuntu VM 12.04 mozilla-beta opt test reftest
- Ubuntu VM 12.04 mozilla-beta pgo test reftest
- Ubuntu VM 12.04 mozilla-central debug test reftest
- Ubuntu VM 12.04 mozilla-central opt test reftest
- Ubuntu VM 12.04 mozilla-central pgo test reftest
- Ubuntu VM 12.04 mozilla-esr31 debug test reftest
- Ubuntu VM 12.04 mozilla-esr31 opt test reftest
- Ubuntu VM 12.04 mozilla-esr31 pgo test reftest
- Ubuntu VM 12.04 mozilla-inbound debug test reftest
- Ubuntu VM 12.04 mozilla-inbound opt test reftest
- Ubuntu VM 12.04 mozilla-inbound pgo test reftest
- Ubuntu VM 12.04 mozilla-release debug test reftest
- Ubuntu VM 12.04 mozilla-release opt test reftest
- Ubuntu VM 12.04 mozilla-release pgo test reftest
- Ubuntu VM 12.04 oak debug test reftest
- Ubuntu VM 12.04 oak opt test reftest
- Ubuntu VM 12.04 try debug test reftest
- Ubuntu VM 12.04 try opt test reftest
- Ubuntu VM 12.04 try pgo test reftest
- Ubuntu VM 12.04 ux debug test reftest
- Ubuntu VM 12.04 ux opt test reftest
Comment on attachment 8534596 [details] [diff] [review]
Break reftest into two chunks on linux32 on all branches,

Review of attachment 8534596 [details] [diff] [review]:
-----------------------------------------------------------------

your last comment was that cedar was running well and that you would land on trunk branches. why did you switch to landing across all branches? Did you not want this to ride the trains? my fear is the lack of testing and not knowing if we need to uplift any bits of the reftest harness or in tree configs to support chunking.

r+ if you explain how above concern is n/a or has already been addressed :D

::: mozilla-tests/config.py
@@ +651,4 @@
>  
>  UNITTEST_SUITES = {
>      'opt_unittest_suites': MOCHITEST + REFTEST_NO_IPC + XPCSHELL + CPPUNIT + MOCHITEST_DT,
> +    'opt_unittest_suites_chunked_reftest': MOCHITEST + REFTEST_TWO_CHUNKS + XPCSHELL + CPPUNIT + MOCHITEST_DT,

I guess the advantage doing it this way is we don't have to rip out REFTEST_NO_IPC and then explicitly say whether we want REFTEST_TWO_CHUNKS or REFTEST_NO_IPC on each platform. Makes sense but feels kind of wrong defining a 'global'ish UNITTEST_SUITES['opt_unittest_suites_chunked_reftest']. Since I don't have a better solution, lgtm :)
Attachment #8534596 - Flags: review?(jlund) → review+
(Assignee)

Comment 15

3 years ago
Created attachment 8535810 [details] [diff] [review]
Split reftest into two chunks on linux32 for gecko >= 37,

I think I was naively assuming it would work everywhere since we didn't have to tweak anything on cedar.  This only applies the change to gecko >= 37.
Attachment #8535810 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Attachment #8534596 - Attachment is obsolete: true
(Assignee)

Comment 16

3 years ago
Builders added:
+ Ubuntu VM 12.04 ash debug test reftest-1
+ Ubuntu VM 12.04 ash debug test reftest-2
+ Ubuntu VM 12.04 ash opt test reftest-1
+ Ubuntu VM 12.04 ash opt test reftest-2
+ Ubuntu VM 12.04 b2g-inbound debug test reftest-1
+ Ubuntu VM 12.04 b2g-inbound debug test reftest-2
+ Ubuntu VM 12.04 b2g-inbound opt test reftest-1
+ Ubuntu VM 12.04 b2g-inbound opt test reftest-2
+ Ubuntu VM 12.04 b2g-inbound pgo test reftest-1
+ Ubuntu VM 12.04 b2g-inbound pgo test reftest-2
+ Ubuntu VM 12.04 cypress debug test reftest-1
+ Ubuntu VM 12.04 cypress debug test reftest-2
+ Ubuntu VM 12.04 cypress opt test reftest-1
+ Ubuntu VM 12.04 cypress opt test reftest-2
+ Ubuntu VM 12.04 elm debug test reftest-1
+ Ubuntu VM 12.04 elm debug test reftest-2
+ Ubuntu VM 12.04 elm opt test reftest-1
+ Ubuntu VM 12.04 elm opt test reftest-2
+ Ubuntu VM 12.04 fig debug test reftest-1
+ Ubuntu VM 12.04 fig debug test reftest-2
+ Ubuntu VM 12.04 fig opt test reftest-1
+ Ubuntu VM 12.04 fig opt test reftest-2
+ Ubuntu VM 12.04 fx-team debug test reftest-1
+ Ubuntu VM 12.04 fx-team debug test reftest-2
+ Ubuntu VM 12.04 fx-team opt test reftest-1
+ Ubuntu VM 12.04 fx-team opt test reftest-2
+ Ubuntu VM 12.04 fx-team pgo test reftest-1
+ Ubuntu VM 12.04 fx-team pgo test reftest-2
+ Ubuntu VM 12.04 holly debug test reftest-1
+ Ubuntu VM 12.04 holly debug test reftest-2
+ Ubuntu VM 12.04 holly opt test reftest-1
+ Ubuntu VM 12.04 holly opt test reftest-2
+ Ubuntu VM 12.04 jamun debug test reftest-1
+ Ubuntu VM 12.04 jamun debug test reftest-2
+ Ubuntu VM 12.04 jamun opt test reftest-1
+ Ubuntu VM 12.04 jamun opt test reftest-2
+ Ubuntu VM 12.04 maple debug test reftest-1
+ Ubuntu VM 12.04 maple debug test reftest-2
+ Ubuntu VM 12.04 maple opt test reftest-1
+ Ubuntu VM 12.04 maple opt test reftest-2
+ Ubuntu VM 12.04 mozilla-central debug test reftest-1
+ Ubuntu VM 12.04 mozilla-central debug test reftest-2
+ Ubuntu VM 12.04 mozilla-central opt test reftest-1
+ Ubuntu VM 12.04 mozilla-central opt test reftest-2
+ Ubuntu VM 12.04 mozilla-central pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-central pgo test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound debug test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound debug test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound opt test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound opt test reftest-2
+ Ubuntu VM 12.04 mozilla-inbound pgo test reftest-1
+ Ubuntu VM 12.04 mozilla-inbound pgo test reftest-2
+ Ubuntu VM 12.04 oak debug test reftest-1
+ Ubuntu VM 12.04 oak debug test reftest-2
+ Ubuntu VM 12.04 oak opt test reftest-1
+ Ubuntu VM 12.04 oak opt test reftest-2
+ Ubuntu VM 12.04 try debug test reftest-1
+ Ubuntu VM 12.04 try debug test reftest-2
+ Ubuntu VM 12.04 try opt test reftest-1
+ Ubuntu VM 12.04 try opt test reftest-2
+ Ubuntu VM 12.04 try pgo test reftest-1
+ Ubuntu VM 12.04 try pgo test reftest-2
+ Ubuntu VM 12.04 ux debug test reftest-1
+ Ubuntu VM 12.04 ux debug test reftest-2
+ Ubuntu VM 12.04 ux opt test reftest-1
+ Ubuntu VM 12.04 ux opt test reftest-2
Builders removed
- Ubuntu VM 12.04 ash debug test reftest
- Ubuntu VM 12.04 ash opt test reftest
- Ubuntu VM 12.04 b2g-inbound debug test reftest
- Ubuntu VM 12.04 b2g-inbound opt test reftest
- Ubuntu VM 12.04 b2g-inbound pgo test reftest
- Ubuntu VM 12.04 cypress debug test reftest
- Ubuntu VM 12.04 cypress opt test reftest
- Ubuntu VM 12.04 elm debug test reftest
- Ubuntu VM 12.04 elm opt test reftest
- Ubuntu VM 12.04 fig debug test reftest
- Ubuntu VM 12.04 fig opt test reftest
- Ubuntu VM 12.04 fx-team debug test reftest
- Ubuntu VM 12.04 fx-team opt test reftest
- Ubuntu VM 12.04 fx-team pgo test reftest
- Ubuntu VM 12.04 holly debug test reftest
- Ubuntu VM 12.04 holly opt test reftest
- Ubuntu VM 12.04 jamun debug test reftest
- Ubuntu VM 12.04 jamun opt test reftest
- Ubuntu VM 12.04 maple debug test reftest
- Ubuntu VM 12.04 maple opt test reftest
- Ubuntu VM 12.04 mozilla-central debug test reftest
- Ubuntu VM 12.04 mozilla-central opt test reftest
- Ubuntu VM 12.04 mozilla-central pgo test reftest
- Ubuntu VM 12.04 mozilla-inbound debug test reftest
- Ubuntu VM 12.04 mozilla-inbound opt test reftest
- Ubuntu VM 12.04 mozilla-inbound pgo test reftest
- Ubuntu VM 12.04 oak debug test reftest
- Ubuntu VM 12.04 oak opt test reftest
- Ubuntu VM 12.04 try debug test reftest
- Ubuntu VM 12.04 try opt test reftest
- Ubuntu VM 12.04 try pgo test reftest
- Ubuntu VM 12.04 ux debug test reftest
- Ubuntu VM 12.04 ux opt test reftest
We definitely want this on 36 too. Beta35 "only" takes ~100min, so we can probably forgo that.
(Assignee)

Comment 18

3 years ago
Created attachment 8535846 [details] [diff] [review]
Split reftest into two chunks on linux32 for gecko >= 37,

Expand the change to include mozilla-aurora (low risk) per RyanVM.
Attachment #8535846 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Attachment #8535810 - Attachment is obsolete: true
Attachment #8535810 - Flags: review?(jlund)
Comment on attachment 8535846 [details] [diff] [review]
Split reftest into two chunks on linux32 for gecko >= 37,

Review of attachment 8535846 [details] [diff] [review]:
-----------------------------------------------------------------

looks good to me :)

::: mozilla-tests/config.py
@@ +1924,4 @@
>                  if slave_platform in BRANCHES[name]['platforms'][platform]:
>                      BRANCHES[name]['platforms'][platform][slave_platform]['opt_unittest_suites'] += REFTEST_IPC
>  
> +# reftest is chunked on linux32 for gecko > 36

s/>/>=/
Attachment #8535846 - Flags: review?(jlund) → review+
(Assignee)

Comment 20

3 years ago
Comment on attachment 8535846 [details] [diff] [review]
Split reftest into two chunks on linux32 for gecko >= 37,

https://hg.mozilla.org/build/buildbot-configs/rev/847725a71b7e
Attachment #8535846 - Flags: checked-in+
(Assignee)

Comment 22

3 years ago
Seems to be running OK now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.