[Notes] Keyboard will overlap image options when long pressing an image in Notes app

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Notes
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: SalvadorR, Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, tracking-b2g:+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8523084 [details]
logcat_20141114_1036.txt

Description:
When attaching an image to to a note in Note app and user brings up the keyboard, if user long presses the image, the keyboard will overlap the image options
   
Repro Steps:
1) Update a Flame device to BuildID: 20141114001204
2) Go to Marketplace and download Notes app
3) In a new note, attach an image to the note
4) Select oustide of the image to bring up the keyboard
5) Long press the attached image and observe keyboard overlap
  
Actual:
Keyboard overlaps image options
  
Expected: 
Keyboard goes away
  
Environmental Variables:
Device: Flame 2.1 (319mb) KK Shallow Flash
BuildID: 20141114001204
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 551326425826
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 3/3
See attached: Video, Logcat
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue also occurs on Flame 2.0

Result: Keyboard overlaps image options

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141114000200
Gaia: 28991b28d54fc4ef8112c8fa678bf20f9faca8c8
Gecko: 62294be0fc98
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
----------------------------------------------------------------------
This issue does not occur on Flame 2.2

Result: Keyboard disappears

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
(Reporter)

Comment 2

4 years ago
Link to video of issue : http://youtu.be/qEQq7oXCMMA
[Blocking Requested - why for this release]:

Nominating this to block 2.1. Poor user flow. Looks like a blank page. Also a regression
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
QA Contact: ckreinbring

Updated

4 years ago
status-b2g-v2.0: unaffected → affected
Given this is across different version of FxOS, I suspect its an app issue. NI Thomas can you help on this or redirect to the right folks on marketplace who can help here? Thanks!
Flags: needinfo?(telin)
Moving to tracking but wouldn't block on this. Also comment #1 reports that this reproduces on 2.0 so I'm not sure this is a regression. 

Agreed this is likely an app issue. Both Browser and Messages handle this situation gracefully in 2.2.
blocking-b2g: 2.1? → -
tracking-b2g: --- → +
Flags: needinfo?(telin)
Regression window
Last working
BuildID: 20140821174517
Gaia: c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko: fbeafa6009e2
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140821180417
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: 66bd2a802b69
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: c8e93dadeaec6a2617b4db8b7d65ba14aa8db378
Gecko: 66bd2a802b69
Broken Gaia / Working Gecko = Repro
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: fbeafa6009e2
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/c8e93dadeaec6a2617b4db8b7d65ba14aa8db378...afcdd36f13e75adcdebe57d842a277fd587faf28


B2G Inbound
Last working
BuildID: 20140821063314
Gaia: 0368ef53e524dfac5c6d1a12a2e5938e7785ff60
Gecko: 3534dcf87eef
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140821070414
Gaia: 1166fa5ebeeaac147e97e4cf71b784ddbc7cd91d
Gecko: 5984c758bb39
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: 0368ef53e524dfac5c6d1a12a2e5938e7785ff60
Gecko: 5984c758bb39
Broken Gaia / Working Gecko = Repro
Gaia: 1166fa5ebeeaac147e97e4cf71b784ddbc7cd91d
Gecko: 3534dcf87eef
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/0368ef53e524dfac5c6d1a12a2e5938e7785ff60...1166fa5ebeeaac147e97e4cf71b784ddbc7cd91d
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Comment 1 is incorrect (reversed) in its thinking of what is affected, unaffected. Fixing flags.


Regression window points to fix from Bug 1048009 as the cause of this bug. Can you take a look Vivien?
Blocks: 1048009
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.0: affected → unaffected
Flags: needinfo?(jmitchell) → needinfo?(21)
QA Contact: ckreinbring

Comment 8

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.