Closed Bug 1099327 Opened 6 years ago Closed 3 years ago

[Settings] When tapping on sim settings in messaging settings emergency alert switch toggles to ON position

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: rmitchell, Unassigned)

References

()

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(1 file)

Description:
When tapping on sim settings in messaging settings emergency alert is toggled when the page is loading


Repro Steps:
1) Update a Flame to 20141114040205
2) with settings app closed reopen settings app 
3) go to messaging settings 
4) tap a sim in sim settings


Actual:
Emergency alert toggles needlessly to its position


Expected:
Alert does not toggle unless pressed 

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141114001204
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 551326425826
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency:25%, 
See attached:logcat video clip:https://www.youtube.com/watch?v=fs3wNBJKGrM
Flags: needinfo?(dharris)
This issue DOES  occur on  2.2 (319mb)(Kitkat Base)(Shallow Flash)
flicker occurs

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------------------------------

issue does not occur on 2.0 (319mb)(Kitkat Base)(Shallow Flash) 
screen does not exist 
Flame 2.0 

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141113000201
Gaia: ab83632c92f9fc571b11d8468b6901cc4ed905c0
Gecko: e21bf45e6c44
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Not nominating to block. This is extremely low repro, and a very minor flickering.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
Reopening. This issue still occurs after bug 1137203 has been fixed.
Emergency Alert displays toggle animation during menu transition.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Resolution: DUPLICATE → ---
Summary: [Settings] When tapping on sim settings in messaging settings emergency alert visual issues occur → [Settings] When tapping on sim settings in messaging settings emergency alert switch toggles to ON position
I've updated the URL to point to a working, current video of the issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 6 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.