[Settings]The Mozilla link within the "Obtaining Source Code" legal page takes the user to a blank page

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: cnelson, Assigned: arthurcc)

Tracking

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-Exploratory-3][p=1], URL)

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8523190 [details]
log.txt

When the user clicks on the Mozilla link located within the "Obtaining Source Code" legal page, they will be taken to a blank page.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141114001204
2) Open the settings app, and select device information.
3) Then select legal information, and tap on obtaining source code option.
4) Scroll down to the bottom of the page, and tap on the Mozilla link highlighted in blue.
5) Notice the user will get taken to a blank page.
  
Actual:
The Mozilla link within the "Obtaining Source Code" legal page takes the user to a blank page.
  
Expected: 
Clicking the link takes the user to the correct page.
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114001204
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 551326425826
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: logcat, video clip https://www.youtube.com/watch?v=MyrADRz4zn8
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue does occur on Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash).

The Mozilla link within the "Obtaining Source Code" legal page takes the user to a blank page.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141114000200
Gaia: 28991b28d54fc4ef8112c8fa678bf20f9faca8c8
Gecko: 62294be0fc98
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

This issue doesn't occur on Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash).

Clicking the link takes the user to the correct page.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]:

This brings the user to a blank page. The user cannot view the previous page until settings is force closed and then reopened. Nominating to block 2.0 for this reason.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

[Triage] Worth to check, but not in 2.0 considering the timing. Nom. to 2.1.
blocking-b2g: 2.0? → 2.1?

Comment 4

3 years ago
Hi Evelyn:
 Could you please help assign a member to check "Obtaining Source Code" URL is valid or not?

Thanks!!
Shawn
Flags: needinfo?(ehung)

Comment 5

3 years ago
Triage: feature not working, blocks.
Assignee: nobody → arthur.chen
blocking-b2g: 2.1? → 2.1+
Status: NEW → ASSIGNED
Whiteboard: [2.1-Exploratory-3] → [2.1-Exploratory-3][p=1]
Target Milestone: --- → 2.1 S9 (21Nov)
Created attachment 8525051 [details]
PR against v2.1

EJ, could you help review the simple patch? Thanks.
Attachment #8525051 - Flags: review?(ejchen)
Created attachment 8525058 [details]
PR against v2.0
Attachment #8525058 - Flags: review?(ejchen)
Comment on attachment 8525051 [details]
PR against v2.1

r+, thanks Arthur !
Attachment #8525051 - Flags: review?(ejchen) → review+
Comment on attachment 8525058 [details]
PR against v2.0

r+, thanks Arthur !
Attachment #8525058 - Flags: review?(ejchen) → review+

Comment 10

3 years ago
clear my ni since everything is on-going.
Flags: needinfo?(ehung)
Duplicate of this bug: 1099407
Open source page on master has the same issue. Mark as affected.
status-b2g-v2.2: unaffected → affected
Created attachment 8525767 [details]
PR against master

EJ, could you help review the patch against master? Thanks.
Attachment #8525767 - Flags: review?(ejchen)
Comment on attachment 8525058 [details]
PR against v2.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users are not able to navigate back to settings app
[Testing completed]: Manual test is completed.
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: N/A
Attachment #8525058 - Flags: approval-gaia-v2.0?
Comment on attachment 8525051 [details]
PR against v2.1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users are not able to navigate back to settings app
[Testing completed]: Manual test is completed.
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: N/A
Attachment #8525051 - Flags: approval-gaia-v2.1?
Duplicate of this bug: 1099435
waiting for master landing before approving here.
Comment on attachment 8525767 [details]
PR against master

r+, thanks Arthur !
Attachment #8525767 - Flags: review?(ejchen) → review+
Thanks, EJ.

master: 18b075b0b7d083ac4f27dc4f837f6e6bde85c2bc
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED

Updated

3 years ago
Attachment #8525051 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Arthur can you also merge this to 2.1 repo so this is present in tomorrow's builds for QA to verify. Thanks!
Flags: needinfo?(arthur.chen)
Keywords: verifyme
v2.1: 97f62f5565272808c60b69cec55703361a9ce4f9
status-b2g-v2.1: affected → fixed
Flags: needinfo?(arthur.chen)

Comment 22

3 years ago
Verified the issue is fixed on 2.2 and 2.0 Flame

the "Obtaining Source Code" legal page navigates to the webpage

"Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

3 years ago
Attachment #8525058 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+

Updated

3 years ago
blocking-b2g: 2.1+ → 2.0+
status-b2g-v2.0M: --- → fixed

Comment 24

3 years ago
Verified the issue is fixed on 2.0 Flame KK

the "Obtaining Source Code" legal page navigates to the webpage

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141205000201
Gaia: 856863962362030174bae4e03d59c3ebbc182473
Gecko: e40fe21e37f1
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
Flags: needinfo?(ktucker)
Created attachment 8533039 [details]
video

This issue has been verified successfully on woodduck 2.0
See attachment: Verify_1099374.MP4
Reproducing rate: 0/3

Woodduck2.0 build:
Gaia-Rev        ead3b72a84512750bc5faff4e9e8faa1715c0d05
Gecko-Rev       c715df57d1d1593ede48140ebc88e101f8c3f7da
Build-ID        20141208050313
Version         32.0
status-b2g-v2.0M: fixed → verified
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.