Default width for <HR> rule is not honored inside a table cell

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Wenqing Jiang, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011112
BuildID:    20011112

The following is a very simple html file.  View it by
IE and then by mozilla and you'll see the difference.

<HTML>
<HEAD><TITLE>theTitile</TITLE></HEAD>
<BODY>
  <TABLE BORDER="1">
    <TR>
      <TD>top left</TD>
      <TD>top right</TD>
    </TR>
    <TR><TD COLSPAN="2"><HR SIZE="2" ALIGN="center" COLOR="#ADADAD"></TD></TR>
    <TR>
      <TD>bottom left</TD>
      <TD>bottom right</TD>
    </TR>
  </TABLE>
</BODY>
</HTML>


Reproducible: Always
Steps to Reproduce:
1. put the html content in the description into file a.htm
2. open that a.htm
3. you can see in the middle of the table the line is shortened to a dot.

Actual Results:  a dot in the middle of the table

Expected Results:  a line in the middle of the table

Comment 1

16 years ago
same result as reported.
I have
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011112

Comment 2

16 years ago
1) Because the default horizontal rule width is the same as the width of the
content area, the value of the "ALIGN" attribute is not noticeable unless a
different rule width is specified using the "WIDTH" attribute. This is why your
<HR> is not centered. You must add a WIDTH attribute to the <HR> rule. No
problem for Mozilla here.

2) COLOR attribute is not supported by the W3C standard.

3) from WIDTH definition in W3C site
http://www.w3.org/TR/html401/present/graphics.html : "The default width is 100%,
i.e., the rule extends across the entire canvas". So when WIDTH is not present,
100% width must be assumed. This is how IE works for HRs, regardless of their
position. Mozilla assumes 100% default width only out of tables, while inside
them the default width becomes 1 pixel ! 

So this bug should be renamed to "Default width for <HR> rule is not honored
inside a table cell" and belongs to Browser->Layout.
Good call, Dimitrios. Marking NEW and -> Layout.

Old summary:
"table content not rendering correctly"

New summary:
"Default width for <HR> rule is not honored inside a table cell"

Related bugs: bug 81776?

Reporter: Your testcase is appreciated. In future, though, please use the
"Create a New Attachment" link for testcases, as that allows developers to save
the step of saving the testcase to disk :).
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
Keywords: testcase
QA Contact: doronr → petersen
Summary: table content not rendering correctly → Default width for <HR> rule is not honored inside a table cell

Comment 4

16 years ago
Created attachment 63391 [details]
HTML snippet that shows functional and non-functional <HR> widths inside cells

The <HR> width appears to work within tables most of the time. It defaults to
one pixel when the <HR> contains an ALIGN= option /and/ the </td> is flush
against the <HR ALIGN="left"> tag.

View attachment for examples of things working correctly and incorrectly.

Comment 5

16 years ago
Additional - I see this behavior on Moz. build 2002010308 on Linux. Platform/OS
should probably be changed to "All"

Comment 6

16 years ago
Joe, FYI, all these icky <HR> bugs depend on some other bug to reorganize the code.

Attinasi told me this... I bet this bug is unfixable (without breaking something
else) unless that bug gets fixed.  :-/

Comment 7

16 years ago
If that's the case and the defect number is known, can it be added to the
"blocks" field of this defect?

Updated

16 years ago
Target Milestone: --- → Future

Comment 8

16 years ago
*** Bug 125507 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
.
Assignee: attinasi → table
Component: Layout → Layout: Tables
QA Contact: petersen → amar

Comment 10

15 years ago
This seems to work now. The test case I attached on Jan 3, 2002 displays
correctly with Moz build 20021117.
(Reporter)

Comment 11

15 years ago
Yes, the abnormity is gone.  Should I (reporter) mark it fixed?

Comment 12

15 years ago
> Should I (reporter) mark it fixed?

FIXED is reserved for bugs fixed by code patches
this bug is WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.