[Contacts] There is no scroll bar on the main contacts page

RESOLVED INVALID

Status

Firefox OS
Gaia::Contacts
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8523236 [details]
logcat

Description:
When users are scrolling through the contacts there is no scrollbar that appears on the right side of the screen.

Repro Steps:
1) Update a Flame to 20141114040205
2) Enter contacts page
3) Add enough contacts that the user can scroll the page
4) Scroll through contacts
5) Observe left part of page

Actual:
There is no scroll bar on the main contacts page

Expected:
It is expected that there is a scroll bar on pages that are scrollable

Environmental Variables:
Device: Flame 2.2
Build ID: 20141114040205
Gaia: 1e300eac2e56d98ad51d414766d031db7d33221f
Gecko: bbb68df450c2
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
This issue also occurs on flame 2.1 and 2.0.

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141114001204
Gaia: af6533781356acc62b0f40c9e040aa5b47d3b709
Gecko: 551326425826
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141114000200
Gaia: 28991b28d54fc4ef8112c8fa678bf20f9faca8c8
Gecko: 62294be0fc98
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
There is no scroll bar present in contacts.
-----------------------------------------------------
The original build this was found in was shallow flashed and set to 319mb.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Do we need the scrollbar when we have the alphascroll, Carrie?
Flags: needinfo?(cawang)
AFAIK, this was hidden by design in all versions (even 1.0.1).
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Flags: needinfo?(cawang)
replacing the needinfo that accidentally got scrubbed with mine.
Flags: needinfo?(cawang)
Nope! Our alphascroll doesn't go with the scroll bar. So this is by design. Thanks!
Flags: needinfo?(cawang)
Per comment 3 and comment 5.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
This is a bad design in my opinion. On my Android phone it has the alphabet picker AND an indicator telling me where I'm at/how far I'm on the list.

It has NO indication of this at all on current design. NI Johan to reconsider this design.
Flags: needinfo?(jlorenzo)
[Tracking Requested - why for this release]:

Thanks for your feedback Pi Wei, we can add this to the backlog so it can be discussed if it could be a new feature for future releases.
tracking-b2g: --- → backlog
Flags: needinfo?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.