[Homescreen][App-permission]occurs always

RESOLVED INVALID

Status

Firefox OS
Gaia::Everything.me
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: ankit93040, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [g+][LibGLA,TD104109,WW, B] )

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

-Social > App Permission > "Hide info/ More info" Link select > Home key > Social App Permission pop-up occurs when entering



Actual results:

-Social App Permission pop-up occurs when entering


Expected results:

-Social entering popup App Permission should not occur.
(Reporter)

Updated

3 years ago
Whiteboard: [g+][LibGLA,TD104109,WW, B]
(Reporter)

Comment 1

3 years ago
Please give your feedback on this whether this is an issue or not.

This happens with only collections & not with other gaia apps.

Thank you
Flags: needinfo?(kgrandon)
Ankit - thank you for filing. I am not sure I fully understand the problem. Any chance you would be able to provide us with a video/screenshot of the issue?
Flags: needinfo?(kgrandon) → needinfo?(ankit93040)
See Also: → bug 1099499
Adding qawanted - is anyone able to reproduce this?
Keywords: qawanted
(Reporter)

Comment 4

3 years ago
STR:

1. Go to collection let's say Music.
2. App-permission window comes.
3. Press home button.
4. Again go to collection Music.
5. App-permission window comes again.

Try the same thing with camera app instead of Music collection. App-permission doesn't come in step 5.

Uploading video for the same. I tested it on V2.0. Reproducible on Flame. Sorry as in didn't test it on Master or v2.1.

Thank you
Flags: needinfo?(ankit93040)
(Reporter)

Comment 5

3 years ago
Created attachment 8523479 [details]
CAM00134.3gp
(Reporter)

Updated

3 years ago
Flags: needinfo?(kgrandon)
(Reporter)

Comment 6

3 years ago
Needinfo'd you as this is done from system app.
Flags: needinfo?(alive)
I don't understand. It's asking the user to grant/deny the permission, why should we hide the permission request? What's the problem to re-show the permission dialog since you did not grant nor deny it?
Flags: needinfo?(alive)
I think that the difference here is that the collection closes after pressing home, but the camera just goes to the background. If you close and re-open the camera, it should also ask you again.

I'm not sure if this is something that we need to fix.
Flags: needinfo?(kgrandon)
(Reporter)

Comment 9

3 years ago
Resolving this as 'Not an issue'. I am satisfied with https://bugzilla.mozilla.org/show_bug.cgi?id=1099503#c8.

So, resolving this.

Thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.