If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

charset changing on form button clicking (Firefox Vers. 33.1.1)

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: easy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8523397 [details]
charset_bug_ezgidiyari_com.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

On my site http://www.ezgidiyari.com if I search entries over the button right "Türkü Ara" the charset change and I see not correct turkish character. But if I click letters on top menu A,B, etc. its working correct. I use PHP script. This phenomenon comes after my last firefox update (33.1.1). I have test my site with other browsers like Chrome, Safira or Internet Explorer. With these browsers my site display correctly. I hope you can solve my isssue? Best thanks.
Easy (Germany)


Actual results:

Charset change with clicking the button on the right site. With clicking on top menu Letters its work ok. The search logic is the same. 


Expected results:

The characters are not correct diplayed in turkish language
with other browsers it works correctly.

Comment 1

3 years ago
Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9f63bbc00527&tochange=423b9c30c73d

hsivonen, is it a valid bug?
Blocks: 871161
Flags: needinfo?(hsivonen)
Right now, this works for me. However, the likely reason why this might not have worked at one time or another is most likely related to circumstances when Firefox doesn't look past the first 1024 bytes of the input for the character encoding declaration (in this case <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-9"/>). The site puts a number of other <meta> tags with potentially variable length before the character encoding declaration.

Reporter, since this is your site, I suggest you move the character encoding declaration up so that it comes right after <head> and let the other <meta> tags come after it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(hsivonen)
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

3 years ago
Thank you very much. I see the big with charset later too. I have change my code, now it works corretctly. Thanks again.
You need to log in before you can comment on or make changes to this bug.