N622 crash [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ]

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
--
critical
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Jan Carpenter, Assigned: dveditz)

Tracking

({crash, topcrash})

Trunk
x86
Windows 98
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This bug is a topcrasher for N620

 Count   Offset    Real Signature
[ 13   KERNEL32.DLL + 0xb992 (0xbff7b992) f111f20e -
nsXPInstallManager::OnStopRequest ]
 
     Crash date range: 2001-11-05 to 2001-11-12
     Min/Max Seconds since last crash: 409 - 56552
     Min/Max Runtime: 409 - 56607
     Keyword List :  
     Count   Platform List 
     13   Windows 98 4.10 build 67766446
 
     Count   Build Id List 
     13   2001102218
 
     No of Unique Users        13
 
 Stack trace(Frame) 

	 KERNEL32.DLL + 0xb992 (0xbff7b992)  
	 nsXPInstallManager::OnStopRequest
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 769] 
	 nsFTPChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFTPChannel.cpp  line 582] 
	 DataRequestForwarder::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp
 line 278] 
	 nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 162] 
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591] 
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524] 
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072] 
	 KERNEL32.DLL + 0x24407 (0xbff94407)  
	 0x00688b5e   

COMMENTS/URLs:
 
     (37919180)	Comments: trying to download a plugin. it screws up more than it should
     (37888326)	URL: westie@ligtel.com.
     (37845707)	Comments: Entering game room form home page. Tried to download showbiz slots
     (37637711)	Comments: was downloading jave 2 plugin for netscape 6. Cancelled the
download and communicator failed.This feedback has never
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash
(Reporter)

Comment 1

17 years ago
changing topcrash bugs to critical
Severity: normal → critical

Comment 2

16 years ago
updating summary with N621, since this is also a crash with Netscape 6.21:
Count   Offset    Real Signature
[ 18   KERNEL32.DLL + 0xb992 (0xbff7b992) 230833d2 -
nsXPInstallManager::OnStopRequest ]
 
     Crash date range: 2002-01-11 to 2002-01-22
     Min/Max Seconds since last crash: 1818 - 196362
     Min/Max Runtime: 1818 - 734014
     Keyword List :  
     Count   Platform List 
     18   Windows 98 4.10 build 67766446
 
     Count   Build Id List 
     18   2001112815
 
     No of Unique Users        18
 
 Stack trace(Frame) 

	 KERNEL32.DLL + 0xb992 (0xbff7b992)  
	 nsXPInstallManager::OnStopRequest
[c:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 769] 
	 nsFTPChannel::OnStopRequest
[c:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFTPChannel.cpp  line 582] 
	 DataRequestForwarder::OnStopRequest
[c:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp
 line 278] 
	 nsOnStopRequestEvent::HandleEvent
[c:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 162] 
	 PL_HandleEvent
[c:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591] 
	 PL_ProcessPendingEvents
[c:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524] 
	 _md_EventReceiverProc
[c:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072] 
	 KERNEL32.DLL + 0x24407 (0xbff94407)  
	 0x00688b4e   
 
     (1897090)	Comments: closing the download windows
     (1864114)	URL: www.camsathome.com
     (1842842)	Comments: Downloading media player
     (1817123)	Comments: Registration
     (1695770)	Comments: there are problems in joinng for chat...being asked for java plug
ins..
     (1632529)	Comments: downloading from ftp.netscape.com


I don't see any of these crashes with recent milestones or trunk builds...so
adding qawanted to see if we can reproduce.
Keywords: qawanted
Summary: N620 crash [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ] → N621 crash [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ]

Comment 3

16 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Comment 4

16 years ago
.
Assignee: scc → dveditz
Component: XP Utilities → Installer: XPInstall Engine
QA Contact: scc → jimmylee
(Assignee)

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 5

16 years ago
Looking at the current Talkback data, I haven't seen anything like this with
recent Milestones or MozillaTrunk builds.  I wonder if this is one of those
crashes that only shows up for Netscape releases.

I was about to mark this one worksforme....but since the owner marked this
nsbeta+ I'll leave it alone.  We've been trying to reproduce this for a long
time and noone has been able to.  I guess we'll keep trying.

Dan:  If you still think this should remain open, QA should try to reproduce
this.  Otherwise you have my blessing to mark this worksforme (according to
Talkback).
(Assignee)

Comment 6

16 years ago
The code in XPInstall has not changed between N621 and M099, although the
networking code might have. Based on where the crash is it looks like maybe the
OnStopRequest is coming in after the nsXPInstallManager has shut itself down and
deleted the triggers.  Hard to see how that could happen since I'd imagine Necko
keeps a reference to us while its sending us messages.

Still worth looking into. To reproduce I'd do what the users are reporting.
Without java installed go to a java site. When prompted to get the plugin
download from Netscape.com, but cancel during the download process. Make sure
we're downloading an ftp: URL and not http:

Comment 7

16 years ago
adt3 per adt traige
Whiteboard: [adt3]

Comment 8

16 years ago
Is this a topcrash for 6.22?

Comment 9

16 years ago
I am not seeing any crash reports on Netscape 6.22. 

Comment 10

16 years ago
Is this a top crash for mozilla 099?
(Assignee)

Comment 11

16 years ago
Do we not have much volume of 6.2.2 reports? I see nothing checked in between
6.21 and 6.22 that would have the remotest affect on this code.
(Assignee)

Comment 12

16 years ago
I don't see this in the top 100 list for 0.9.9 either. In fact, the only
nsXPInstallManager:: stack traces I see in the database at all using the search
page http://climate/ are three in ...::OnProgress() 

Am I using that page correctly? Does it only check matches in the very last
function on the stack?

WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
Created attachment 78005 [details]
Stacks from N622 and M099 terminating at KERNEL32.DLL with XPInstallManager::OnstopRequest in the second frame

Dan, you wouldn't see the crashes for this signature in the top 100 because the
signature is KERNEL32.DLL (as you questioned in comment #12). We have another
report that can look a little deeper for comparisons. I've attached the crashes
that include XPInstallManager::OnStopRequest as the second frame of the stack.
(15 in M099, 71 in N622, 0 in Trunk) The M099 and N622 stacks differ, which I
would expect from two different product installations. All crashes listed are
on Win98 or ME (listed as Windows 98 4.90), no NT platforms.

(There were two crashes that happened on the Trunk at
nsXPInstallManager::OnInstallDone. They are tacked on at the bottom.)

Because crashes/unique users is a 1/1 ratio I would guess a user encounters
this once and succeeds on a subsequent attempt (unless 100% give up entirely or
100% only submit one crash report). We can look deeper into specific users
systems (DLLs loaded, system memory, etc.) if that info can help you pinpoint
the problem. Just Let me know.

Comment 14

16 years ago
Dan, going to reopen this in hopes that the info I included above is helpful. 
And if it's not we should minus it before marking it as WFM.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: N621 crash [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ] → N622 crash [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ]

Comment 15

16 years ago
Doh! reverting to WFM. My above attachment/comments were intended for bug 
109139 - nsXPInstallManager::FinalStatus. 

Also, minusing since I haven't found this signature in the talkback data.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Keywords: nsbeta1+ → nsbeta1-
Resolution: --- → WORKSFORME

Comment 16

16 years ago
Marking Verified per Greer's comments.
Status: RESOLVED → VERIFIED
Crash Signature: [@ KERNEL32.DLL - nsXPInstallManager::OnStopRequest ]
Keywords: qawanted
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.