top of font is sometimes clipped

REOPENED
Unassigned

Status

()

Core
Graphics: Text
REOPENED
3 years ago
2 years ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141114030206

Steps to reproduce:

My display in Windows is set at 125%. I go to most webpages eventually I will see some text where the very top of some letters is clipped.


Actual results:

See screenshots.
In capture.jpg you can see the 5 in Mozilla/5.0 and the lowercase f in Firefox are clipped on the top.
In capture2.jpg you can see every link has letters that are slightly clipped at the top.


Expected results:

Fonts should render without being clipped.
(Reporter)

Comment 1

3 years ago
Created attachment 8523435 [details]
Capture.PNG
(Reporter)

Comment 2

3 years ago
Created attachment 8523436 [details]
Capture2.PNG
Unable to reproduce on 36.0a1 (2014-11-17), Win 7 x64.
Check if switching the HWA ON/OFF makes any difference.
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 4

3 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #3)
> Unable to reproduce on 36.0a1 (2014-11-17), Win 7 x64.
> Check if switching the HWA ON/OFF makes any difference.

Yeah it's hardware acceleration. When I disable it the problem disappears. Also, cleartype is disabled on this machine which may have something to do with it.

Comment 5

3 years ago
Can you provide the graphics portion of about:support ?
Component: Graphics → Graphics: Text
Flags: needinfo?(raysatiro)
(Reporter)

Comment 6

3 years ago
(In reply to :Gijs Kruitbosch from comment #5)
> Can you provide the graphics portion of about:support ?

Sure:

Adapter Description	Intel(R) HD Graphics 3000
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
ClearType Parameters	D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
Device ID	0x0122
DirectWrite Enabled	false (6.2.9200.16571)
GPU #2 Active	false
GPU Accelerated Windows	0/1 Basic (OMTC)
Subsys ID	00000000
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(raysatiro)

Comment 7

3 years ago
Jonathan, I don't suppose you know what's up here? :-)
Flags: needinfo?(jfkthame)
(In reply to :Gijs Kruitbosch from comment #7)
> Jonathan, I don't suppose you know what's up here? :-)

Not really, but my initial guess is that maybe Azure doesn't handle non-antialiased rendering well. Bas should probably have a look.
Flags: needinfo?(jfkthame) → needinfo?(bas)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126577
Un-duping at Jeff's request, Jeff believes these are two different bugs..
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 11

3 years ago
I forgot all about this bug. I don't think I've seen it in a long while. Either that or I've just gotten used to it. I'll be on the lookout now.
(Reporter)

Comment 12

2 years ago
Created attachment 8643456 [details]
Clipboard.png

I no longer see this issue with the bugzilla website however I can at MDN, see

https://developer.mozilla.org/en-US/docs/Mozilla/js-ctypes

With the display set at 125% and regardless of HW accel setting in Aurora the letter l is clipped in the 'Note' section. If I change layout.css.devPixelsPerPx to 1.0 I can see the top of the l but it's taller than it should be. See attached comparison.
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.