Running tests on the elasticsearch branch

RESOLVED WORKSFORME

Status

Webtools
DXR
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: quentinp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8523456 [details]
main-c7b019.c

I have multiple issues with the elasticsearch branch. This bug is about running tests.

I've followed http://dxr.readthedocs.org/en/es/development.html to install the development environment, but I've also ran `vagrant provision` because elasticsearch was not running otherwise. Launching `test_basic` produces: 


$ nosetests tests/test_basic
E
======================================================================
ERROR: test suite for <class 'test_basic.BasicTests'>
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 209, in run
    self.setUp()
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 292, in setUp
    self.setupContext(ancestor)
  File "/usr/local/lib/python2.7/dist-packages/nose/suite.py", line 315, in setupContext
    try_run(context, names)
  File "/usr/local/lib/python2.7/dist-packages/nose/util.py", line 470, in try_run
    return func()
  File "/home/vagrant/dxr/dxr/testing.py", line 179, in setup_class
    run('make')
  File "/home/vagrant/dxr/dxr/testing.py", line 45, in run
    raise CommandFailure(command, status, output)
CommandFailure: 'make' exited with status 512. Output:
# Link paths in dxr.config.in to current working directory
# replaces PWD with `pwd` and produces dxr.config
cat dxr.config.in | sed -e 's?PWD?'`pwd`'?g' > dxr.config
# Navigate into the DXR folder, build using config file
dxr-build.py
 - Generating target folder.
Processing tree 'code'.
Build command for 'code' failed, exited non-zero.
Log follows:
    | make[1]: Entering directory `/home/vagrant/dxr/tests/test_basic/code'
    | rm -rf code
    | make[1]: Leaving directory `/home/vagrant/dxr/tests/test_basic/code'
    | make[1]: Entering directory `/home/vagrant/dxr/tests/test_basic/code'
    | clang++ -Xclang -load -Xclang /home/vagrant/dxr/dxr/plugins/clang/libclang-index-plugin.so -Xclang -add-plugin -Xclang dxr-index -Xclang -plugin-arg-dxr-index -Xclang /home/vagrant/dxr/tests/test_basic/code -o code main.c
    | clang: warning: treating 'c' input as 'c++' when in C++ mode, this behavior is deprecated
    | clang: error: unable to execute command: Segmentation fault (core dumped)
    | clang: error: clang frontend command failed due to signal (use -v to see invocation)
    | Ubuntu clang version 3.5-1ubuntu1 (trunk) (based on LLVM 3.5)
    | Target: x86_64-pc-linux-gnu
    | Thread model: posix
    | clang: note: diagnostic msg: PLEASE submit a bug report to http://bugs.debian.org/ and include the crash backtrace, preprocessed source, and associated run script.
    | clang: note: diagnostic msg: 
    | ********************
    | 
    | PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
    | Preprocessed source(s) and associated run script(s) are located at:
    | clang: note: diagnostic msg: /tmp/main-c7b019.c
    | clang: note: diagnostic msg: /tmp/main-c7b019.sh
    | clang: note: diagnostic msg: 
    | 
    | ********************
    | make[1]: *** [code] Error 254
    | make[1]: Leaving directory `/home/vagrant/dxr/tests/test_basic/code'
 
Running pre_build.
1 of 3 jobs done.
2 of 3 jobs done.
3 of 3 jobs done.
Building the 'code' tree
make: *** [all] Error 1

----------------------------------------------------------------------
Ran 0 tests in 2.778s

FAILED (errors=1)

Should I really report the bug?
(Reporter)

Comment 1

3 years ago
Created attachment 8523457 [details]
main-c7b019.sh
This seems to happen if DXR's clang plugin is turned on, but the actual compiled clang plugin isn't available. You should be able to fix this by running `make` again from the top of the DXR folder.
There were also some segfaults in the clang compiler plugin. Another contributor's experience suggests I accidentally fixed those while revising its location handling. If you would, update to the latest, recreate your Vagrant box, and see if it still happens. If it does, reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.