Closed Bug 1100022 Opened 8 years ago Closed 8 years ago

Cannot login to the Firefox Account

Categories

(Firefox OS Graveyard :: FxA, defect)

defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1096603
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: mcepl, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

When trying to login to the Firefox Account in Settings, I get first beautiful dialog "Firefox Account" which explains what the account is about, and when I click Next, I get what's attached. Whatever I press on the screen (and I don't know what I am pressing) nothing happens.
Component: Gaia::Settings → FxA
Matej, can you tell me what version of FxOS you're running?
(In reply to Sam Penrose from comment #1)
> Matej, can you tell me what version of FxOS you're running?

Nightly, daily updated.
(In reply to Matěj Cepl from comment #2)
> (In reply to Sam Penrose from comment #1)
> > Matej, can you tell me what version of FxOS you're running?
> 
> Nightly, daily updated.

I mean 2.2 from https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame-kk/
Great, thanks very much for reporting this. QA, can you reproduce?

(In reply to Matěj Cepl from comment #3)
> (In reply to Matěj Cepl from comment #2)
> > (In reply to Sam Penrose from comment #1)
> > > Matej, can you tell me what version of FxOS you're running?
> > 
> > Nightly, daily updated.
> 
> I mean 2.2 from
> https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-
> flame-kk/
Keywords: qawanted
Dupe of 1096603, I think. Fix for that bug will be landing today, should be fixed in tomorrow's 2.2 build.

Matej, keep an eye on the other bug and please reopen this one if you still have the problem.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
(In reply to Jared Hirsch [:_6a68] [NEEDINFO pls] from comment #5)
> Dupe of 1096603, I think. Fix for that bug will be landing today, should be
> fixed in tomorrow's 2.2 build.
> 
> Matej, keep an eye on the other bug and please reopen this one if you still
> have the problem.
> 
> *** This bug has been marked as a duplicate of bug 1096603 ***

Yes, the attachment 8520211 [details] looks exactly like what I get.
(In reply to Jared Hirsch [:_6a68] [NEEDINFO pls] from comment #5)
> Matej, keep an eye on the other bug and please reopen this one if you still
> have the problem.

Actually, I do have a problem. I have got now a beautiful next screen, which asks me to fill-in the email address of my account. However, when I tap into it with my finger, the on-screen keyboard briefly jumps up, but immediately hides again, so it is not possible to write anything. So, in the end, this is still kind of broken.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
It seems there is a workaround though: when I leave the phone with this screen on and switch off display (by briefly pressing the power button), then when I open a phone again I get my keyboard.
Hi Matej,

What device are you using? What version of Gaia (specifically, which head commit)? If you're using a Flame, what base image are you using? (It's okay if you're not sure of any of these answers; I can explain how to get the info, or you can ask in #gaia.)

Have you seen this keyboard behavior in any other input fields in the FxA app or in other apps on your device? FxA doesn't do anything special with the keyboard or focus/blur behavior, so I'm wondering if you are maybe seeing bug 1078690?

Cheers,

Jared
Flags: needinfo?(cepl)
Saw this behavior on Flame 2.2 KK in both FTU and in Settings for FxA.

Tested with Shallow Flash on 319mb using Engineering builds.

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: Problems with the keyboard when trying to enter your email in FxA. Keyboard appears then disappears each time you tap in the text field. I eventually got it to stay but had to keep tapping the text field over and over again. However if you go back a page then go forward the issue reappears.

Repro Rate: 3/3

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141119044505
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: aa72ddfe9f93
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, Flame 2.0 KK

Actual Result: Tapping in the text fields for FxA does not produce any problems with the keyboard.

Repro Rate: 0/4

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141117201226
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141118152123
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
(In reply to Jared Hirsch [:_6a68] [NEEDINFO pls] from comment #9)
> What device are you using? What version of Gaia (specifically, which head
> commit)? If you're using a Flame, what base image are you using? (It's okay
> if you're not sure of any of these answers; I can explain how to get the
> info, or you can ask in #gaia.)

Flame, with base 188 and image (updated daily) from https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame-kk/

> Have you seen this keyboard behavior in any other input fields in the FxA
> app or in other apps on your device? FxA doesn't do anything special with
> the keyboard or focus/blur behavior, so I'm wondering if you are maybe
> seeing bug 1078690?

Not so far.
Matej - the 'new' issue you are describing in comment 7 sounds like a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1101707

In the future - it is best to write up a new bug for issues that are not exactly the original issue.

I'd suggest re-closing this because the original issue does not reproduce and the new issue is written up in another bug.
Flags: needinfo?(mcepl)
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Flags: needinfo?(mcepl)
Resolution: --- → DUPLICATE
Flags: needinfo?(cepl)
You need to log in before you can comment on or make changes to this bug.