Closed Bug 11001 Opened 21 years ago Closed 21 years ago

[4.xP] Table spacing&borders incorrect at http://www.choochem.com

Categories

(Core :: Layout: Tables, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: w.k.havinga, Assigned: harishd)

References

()

Details

Overview description: Using <P> to create vertical space between tables does not
work.
Also, borders aren't drawn correctly on the page mentioned above.

Steps to reproduce: go to http://www.choochem.com, or try the snippet I included
below (where the errors are isolated)

Actual results: There is no space in between the tables. Also, there should be
black borders around the tables, they are probably overdrawn by the background
color (because it works correctly for the outermost table!)

Expected results: Look at the code snippet below with any recent Netscape or
Explorer version. There are black borders around every table (this creates nice
boxes), and there should be some vertical space in between them.

Build date&Platform bug found: M8 on linux 2.0.36 (i386)

Additional information:
This code snippet displays the error nicely (use a large window for proper
layout):
<!DOCTYPE HTML PUBLIC "-//W3C//TDT HTML 4.0 Transitional//EN">
<HTML>
<BODY BGCOLOR="#FFFFFF" TEXT="#000000" LINK="#1725D0" ALINK="#172590"
VLINK="#172590">

<TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="1"
BGCOLOR="#000000">
<TR><TD>
        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="10"
BGCOLOR="#1ACFD8">
        <TR VALIGN="TOP"><TD WIDTH="100%">
                <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="0"
BGCOLOR="#000000">
                <TR><TD> <!-- This should create a nice 'border', which isn't
painted, or overwritten -->
                        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="1"
CELLPADDING="5" BGCOLOR="#000000">
                        <TR BGCOLOR="#FFFFF" VALIGN="TOP"><TD>
                                Somestuff
                        </TABLE>
                </TABLE>
                <P> <!-- Here should be some space, but it isn't painted -->
                <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="0"
BGCOLOR="#000000">
                <TR><TD>
                        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="1"
CELLPADDING="5" BGCOLOR="#000000">
                        <TR BGCOLOR="#FFFFFF" VALIGN="TOP"><TD>
                                Morestuff
                        </TABLE>
                </TABLE>
        </TABLE>
</TABLE>
</BODY>

</HTML>
Assignee: karnaze → harishd
Harish, in the simpler example below the parser is not putting the <table>
inside the <p>. When that gets fixed, if there still is a problem with the right
amount of space, please reassign to Kipp.

There should be some space between here and the table
<P>
 <TABLE WIDTH="100%" BORDER="1 CELLSPACING="0" CELLPADDING="0">
  <TR>
   <TD>bar</td></tr>
 </table>
</p>
Per spec. <P> can contain only "inline" elements. <TABLE> happens to be a
block-level element and therefore parser closes <P> before opening <TABLE>.

FYI:  IE allows <P> to contain <TABLE> but it's hard to say in Nav.!!
So your saying that the current behavior is Standard mode only. Nav4.x must be
putting the table inside the <p> because there is a lot of extra space. By
closing the <p> before the table, the space is gone. We need a NavQuirks mode
here, since everybody uses NavQuirks mode.
Target Milestone: M9
CSS 2 defines inline-table as a display type (which we don't yet support), so
unless the parser is looking at display types, it should not be deciding that a
<p> cannot contain a <table>.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Allowing P to contian Table - for compatibility.

Marking bug fixed.
So is this a quirks mode only or always?
Status: RESOLVED → VERIFIED
Using 8/6 Apprunner, verifying that P contains table and therefore bug is fixed
(Nav compatibility)
You need to log in before you can comment on or make changes to this bug.