Edit mailing list dialogue: Recipient autocomplete results popup covers current input box, preventing user from typing in correct address

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
2 years ago

People

(Reporter: ravgershom, Unassigned)

Tracking

31 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141030112145

Steps to reproduce:

Just started typing the address of intended recipient. Autocomplete provides what it thinks is the address, but obscures the box so user cannot type the address.


Actual results:

The address box is obscured


Expected results:

The suggested address should disappear if user keeps on typing
ravgershom, can you explain the exact meaning of "The address box is obscured"? Can you attach a screenshot, after blacking out private data as required?
If you keep on typing, the suggested address WILL disappear if it no longer matches.

I don't think we have a problem here.
Problems come after the fact, when autocomplete might change what you've actually entered.
Flags: needinfo?(ravgershom)
Summary: Auto Address obscures address box with prompt preventing user from typing in correct address → Recipient autocomplete obscures address box with prompt preventing user from typing in correct address
Whiteboard: [closeme 2015-03-23]
(Reporter)

Comment 2

4 years ago
It means what it says. When one starts typing in an address in the "to" field in Thunderbird a box with a prompt comes on and blocks the user from seeing what she's typed, insisting on the "auto-fill's" guess about the intended recipient. That makes it impossible to type in one's own recollection of the correct recipient. I made a screen shot for you but I can't see how to paste if on this form. I've done my best to be a "good citizen" but if you need more you will have to contact me via email.
Flags: needinfo?(ravgershom)
(Reporter)

Comment 3

4 years ago
Created attachment 8570670 [details]
Screen Shot 2015-02-25 at 9.23.02 AM.png
Next time, pls be MUCH more detailed about the steps to reproduce. There was no way we could have guessed from comment 0 that you are talking about the "Edit Mailing List" dialogue in Address Book.

This wfm on Windows 8.
But per screenshot it does seem to fail on OSX.
Summary: Recipient autocomplete obscures address box with prompt preventing user from typing in correct address → Edit mailing list dialogue: Recipient autocomplete results popup covers current input box, preventing user from typing in correct address
Whiteboard: [closeme 2015-03-23]

Comment 5

3 years ago
Seems fixed to me on trunk. The box listing contacts appears below the text field.

I have been adding many contacts to the mailing list untilthe box was full of them excepting the last row. Trying to insert a new one, just by starting typing also shows correctly the auto-completion box.

Just you opened this bug report, there has been at least one release of Thunderbird. Is it still not working as expected?

Updated

3 years ago
Flags: needinfo?(ravgershom)

Comment 6

2 years ago
This bug was opened long ago and there hasn't been answered by the reporter for a year.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(ravgershom)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.