If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RFE no persist option for chromeregistry selectskin method

RESOLVED DUPLICATE of bug 110752

Status

Core Graveyard
Skinability
RESOLVED DUPLICATE of bug 110752
16 years ago
9 years ago

People

(Reporter: rvj, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Future
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Switching to an application skin on startup (during xul onload  event) provides 
a very simple means of applying an application skin (which is totally 
independent of Mozilla skins)

However the selectskin method seems to save (persist) the skin name as a  
Mozilla skin.

A very simple solution would be to have an additional option for the selectskin 
(or refreshskin) method which requests that the skinname is not to be saved


persist='false';
chromeregistry.selectSkin('appskin',, persist);

I think this should be a very simple change.

PS As a workaround, I get the application to restore the default mozilla skin 
when the application is closed but if the application closes abnormally, then 
the mozilla default skin is not restored and Mozilla fails on startup.
(Reporter)

Comment 1

16 years ago
This RFE is invalid if application 'user-skins' files can be specified in the 
package description.

See bug 110752.

Updated

16 years ago
Target Milestone: --- → Future

Comment 2

16 years ago
So, this is INVALID then, or what ...

Comment 3

15 years ago
INVALID by previous comments.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
not really invalid ?

currently user-skins can not be specified in package description and at this 
point the RFE 110752 has not been responded to
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

15 years ago
So is this a dupe of bug 110752 or does this bug depend on that one?

pi

Comment 6

15 years ago
Nobody disagrees to this.

pi

*** This bug has been marked as a duplicate of 110752 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.