[Midori 2.0][Settings][BT]Bluetooth can't search all device

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: shawnjohnjr)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

Details

Attachments

(1 attachment)

10.32 KB, application/octet-stream
Details
(Reporter)

Description

4 years ago
FFOS2.0
 
 DEFECT DESCRIPTION:
 Bluetooth can't search all other devices
 
  REPRODUCING PROCEDURES:
 1.open Bluetooth,search for devices
 2.can't seach all other devices  ---- K.O
 
  REPRODUCING RATE:3/3
 
 
 P.S: I download FFOS1.3 system to the same phone, it can search all other devices, but FFOS2.0 can't.
(Reporter)

Comment 1

4 years ago
Created attachment 8523670 [details]
jrdlog

Comment 2

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.0?

Comment 3

4 years ago
Hi Shawn:
 Could you please help check this issue first?

Thanks!!
Shawn
Flags: needinfo?(shuang)
See also: bug 1077165
Flags: needinfo?(shuang)
Assignee: nobody → shuang

Comment 5

4 years ago
Hi Shawn:
I don't have enough authority to access this bug.
The page show this: 'You are not authorized to access bug #1077165. '

Updated

4 years ago
Flags: needinfo?(shuang)

Comment 6

4 years ago
qawanted to confirm this is also not seen in 1.3 Flame but with 2.0? In 1077165 we see repro. rate much lower w/ 2.0 on Flame. So maybe not OS but more like chipset related?
Keywords: qawanted
This issue can't repro on Flame 2.1, 2.2
Reproducing rate: 0/5
Flame 2.1 build:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141118001204
Version         34.0

Flame 2.2 build:
Gaia-Rev        4aee256937afe9db2520752650685ba61ce6097d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/084441e904d1
Build-ID        20141118144012
Version         36.0a1
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
(In reply to Kunny Liu from comment #5)
> Hi Shawn:
> I don't have enough authority to access this bug.
> The page show this: 'You are not authorized to access bug #1077165. '

I just want to confirm this bug. The description mentioned 'Bluetooth can't search all devices', 'can't seach all other devices'?
Can you elaborate the detail? Do you all the devices cannot be discovered? Or you refer to some of devices cannot be searched and need to search again.
Flags: needinfo?(shuang) → needinfo?(liukun)
(In reply to Kunny Liu from comment #5)
> Hi Shawn:
> I don't have enough authority to access this bug.
> The page show this: 'You are not authorized to access bug #1077165. '

I just want to confirm this bug. The description mentioned 'Bluetooth can't search all devices', 'can't seach all other devices'?
Can you elaborate the detail? Do you mean all the devices cannot be discovered? Or you refer to some of devices cannot be searched and need to search again.

Do you use bluedroid as stack? I guess you're using v1.4 (bluez) and upgrade to v2.0 (bluedroid).

Comment 10

4 years ago
Hi Shawn:
Because attachments cannot be more than 10240 KB, so I create a link:http://pan.baidu.com/s/1kTBT06F
You can get the video which is describe this issue.

From this video you will see this issue clearly:
Left device is FFOS1.3 and right one is FFOS2.0. Here are two abnormal appearances:
1. FFOS2.0 can't search any other BT devices.
2. FFOS2.0 stopped searching even if search time(60s) not elapse.

Do you use bluedroid as stack?  --> Yes.
Flags: needinfo?(liukun)
(In reply to Wesly Huang from comment #6)
> qawanted to confirm this is also not seen in 1.3 Flame but with 2.0? In
> 1077165 we see repro. rate much lower w/ 2.0 on Flame. So maybe not OS but
> more like chipset related?

We don't have permission to read bug 1077165.

I'm unable to reproduce the bug on Flame 2.0. Bluetooth devices can be searched in all 10 attempts.

Device: Flame 2.0
BuildID: 20141118152123
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

(In reply to Kunny Liu from comment #10)
> 2. FFOS2.0 stopped searching even if search time(60s) not elapse.

I can reproduce this on Flame 2.0. The device stops searching (the button 'Search for devices' becomes press-able) after ~13 seconds. But I'm not sure if this test is valid? Is 60 seconds a standard searching time written anywhere?
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
[Triage] Can't repro. in Flame 2.0/2.1/2.2, ten d to be device-specific thus de-nom.
blocking-b2g: 2.0? → ---
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.