[Flame][Homescreen]It will show a blank page and close icon can't work when you open two App folders quickly.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: gduan)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 verified, b2g-v2.1 verified, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments)

2.08 MB, video/mp4
Details
100.09 KB, text/plain
Details
283.80 KB, text/plain
Details
335.53 KB, text/plain
Details
46 bytes, text/x-github-pull-request
kgrandon
: review+
kgrandon
: feedback+
Details | Review
Reporter

Description

5 years ago
Posted video video
[1.Description]:
[Flame][v2.1&v2.2][Homescreen]It will show a blank page and close icon can't work when you open an App folder and then open another one quickly.
Found time:01:00
See attachment: Video_0100.MP4 and logcat_0100.txt

[2.Testing Steps]: 
1.Open a smart collection and confirm it in loading.
2.Back to homescreen.
3.Open another smart collection quickly.
**You can see it show a blank page and not load anything.
4.Tap close icon "X".
** Close icon can't 

[3.Expected Result]: 
3.Smart collection will load content normally.
4.Tap close icon "X" can close smart collection
[4.Actual Result]: 
3.DUT show a blank page and not load anything.
4.Close icon is not available.

[5.Reproduction build]: 
Flame 2.1 versions:
Gaia-Rev        569a299ca446f714cd98d5881cc058fd6f6e257b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/d188e92aa5a6
Build-ID        20141113001200
Version         34.0

Flame 2.2 versions:
Gaia-Rev        be8b0151d2f9a4c41fc63952128e0b723cd1161d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ab137ddd3746
Build-ID        20141113040205
Version         36.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Reporter

Comment 1

5 years ago
Posted file logcat
Reporter

Comment 2

5 years ago
Posted file logcat_0418.txt
Hi Eric,
This issue can be repro on Flame 2.1/2.2, I have uploaded the logcat of Flame 2.2, could you help with it? Thanks!
Found time:04:18
See attachment:logcat_0418.txt
Rate:4/7

Flame 2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.034952
FW-Date         Sat Jan  3 03:50:03 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.045144
FW-Date         Sat Jan  3 04:51:56 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(echang)
ni RD for comment.
Flags: needinfo?(echang) → needinfo?(amirnissim)
Not sure where the bug resides. The collection is opened with the Activity mechanism.
Anywho, since Amir and I are no longer on the project I suggest NI Kevin Grandon.
Flags: needinfo?(amirnissim)
Reporter

Comment 5

4 years ago
Posted file logcat_0341.txt
Hi Eric,
This issue can be repro on latest build of Flame 2.1/2.2/3.0 with the same steps in comment 0, but it can't be repro on latest build of 2.1S(512M). I have uploaded the logcat of Flame 2.2
Per comment 4, could you help to NI Kevin Grandon? Thanks!
Found tiam:03:41
See attachment:logcat_0341.txt
Rate:
Flame 2.1:4/5
Flame 2.2:4/5
Flame 3.0:4/5
2.1S(512M):0/5
Flags: needinfo?(echang)
Reporter

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(echang) → needinfo?(hcheng)
When this problem happens, user needs to restart his/her phone... Nom as a 2.2 blocker.
Kevin, could you take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng) → needinfo?(kgrandon)
I looked into this a bit and I am fairly sure this is a problem with window management and activities. I think the issue is that we are reviving an activity that is in the process of closing, instead of using a new activity. Will look further as time permits.
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Flags: needinfo?(kgrandon)

Comment 8

4 years ago
Triage: blocking. George to take a look first.
Assignee: nobody → gduan
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(alive)
I believe George is on it.
Flags: needinfo?(alive)
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

Currently we use webActivity to launch collection app. However, the old activity listener might steal the new one if they are in the same process (see bug 993188) if the old one is not dead completely.

There might be ways to fix it.
1. set dependency to bug 993188 (suggested, but it takes time)
2. destroy activity immediately when calling requestClose ( might affect the whole system's UX, not suggested)
3. remove activity listener once view_controller.js has received the activity and ready to display( I think this activity would be only triggered once)

I'm not sure if any side effect, please suggest or and better solution, thanks!
Attachment #8587176 - Flags: feedback?(kgrandon)
Attachment #8587176 - Flags: feedback?(crdlc)
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

Seems like a good approach to me. Thanks!
Attachment #8587176 - Flags: feedback?(kgrandon) → feedback+
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

Hi,
could you help me to review it? Thanks. Please let me know if any side effect.
Attachment #8587176 - Flags: feedback?(crdlc) → review?(crdlc)
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

Hi Kevin,
could you also help me to do the review? Chris seems quite busy here. Thanks.
Attachment #8587176 - Flags: review?(crdlc) → review?(kgrandon)
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

LGTM, thanks.
Attachment #8587176 - Flags: review?(kgrandon) → review+
master: https://github.com/mozilla-b2g/gaia/commit/ef61ebbe5de8c2c9fc2a8f74a12455044c3b82e9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8587176 [details] [review]
[gaia] cctuan:1100263 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression.
[User impact] if declined: see comment 0, user might see a empty collection screen while quickly tapping new collection after closing previous one.
[Testing completed]: Yes, I have checked manually.
[Risk to taking this patch] (and alternatives if risky): No.
[String changes made]:
Attachment #8587176 - Flags: approval-gaia-v2.2?
Attachment #8587176 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 19

4 years ago
Verified successfully on flame 2.2&3.0:
Flame 3.0:
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Flame 2.2:
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Reproduce rate     0/10

Updated

4 years ago
Keywords: verifyme
Environmental Variables:
Device: Flame 2.5 Kk Full Flash (319mb)
Build ID: 20150715010202
Gaia: c6ef08964711f461a8e6326eae911789d1ec220c
Gecko: c95ebeebbc5d
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.2 Kk Full Flash (319mb)
Build ID: 20150715002506
Gaia: 84d0c76370dcd3d25813b00de55194730884355b
Gecko: a5db6d9850f6
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 Kk Full Flash (319mb)
Build ID: 20150715001207
Gaia: d13826b20b4a45e3f5cd4b25a30a737d8be7f1b9
Gecko: 92049b3c4bb5
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 Kk Full Flash (319mb)
Build ID: 20150714160200
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 7e5b586e36b7
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Issue is Verified Fixed for the above variables found in Comment 20

Result: Blank page no longer occurs.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.